When I select the face and press "assign material", the material isn't assigned to the face but somehow to parts of it and parts outside of it...

How can I assign a material to this face? enter image description here

  • $\begingroup$ Avoid triangles and n-gons, when subdivided they have this king of behavior. $\endgroup$
    – Denis
    Commented Aug 22, 2015 at 20:34
  • $\begingroup$ you have a subsurf modifier which will change the topology $\endgroup$
    – Chebhou
    Commented Aug 22, 2015 at 20:54
  • $\begingroup$ btw, this might not be an answer to your question, but I think you could make this spaceship look way cooler when you add an edge split modifier and mark some sharp edges with ctrl+e. $\endgroup$
    – Jonathan
    Commented Aug 22, 2015 at 21:13
  • $\begingroup$ Man I understood NOTHING xD skype: Omnitored $\endgroup$
    – Omnitored
    Commented Aug 23, 2015 at 6:41
  • $\begingroup$ So someone can help me? $\endgroup$
    – Omnitored
    Commented Aug 23, 2015 at 18:36

1 Answer 1


You are dealing with two issues: non-planar geometry and the interpolation generated by the subsurf modifier.

Let's start with the second.

The subsurf modifier is designed to make things rounder by subdividing the existing faces and make them smoother. If the faces are too big for the complex shapes you are trying to achieve, you'll see artifacts.

enter image description here

The solution is to edit your mesh with a bit more density so that the shapes are better described. Then the subsurf modifier will not be interpolating the surfaces and it's materials in such a drastic way.

enter image description here

Now, for an explanation of how to deal with non-planar geometry read this answer

  • $\begingroup$ Turned off subsurf, but then the ship looks all different. How do you make those double lines like on the gif. nr. 2? $\endgroup$
    – Omnitored
    Commented Aug 24, 2015 at 4:21
  • $\begingroup$ using the loop cut tool blender.stackexchange.com/a/24419/1853 $\endgroup$
    – user1853
    Commented Aug 24, 2015 at 10:56
  • $\begingroup$ NOOOOPE, almost everything works but ofcourse there is 1 bug.. prntscr.com/88comd Help me fix it? Tryed both ways $\endgroup$
    – Omnitored
    Commented Aug 24, 2015 at 16:10
  • $\begingroup$ For different questions please make a new post. $\endgroup$
    – user1853
    Commented Aug 24, 2015 at 19:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .