4
$\begingroup$

I have imported an svg and I am using the tutorials here: http://spolearninglab.com/curriculum/software/3d_modeling/blender/blender_02.html

and here: https://studiogreenleaf.wordpress.com/2013/11/23/inkscape-to-blender/

It seems pretty straightforward, and I even got it to work with one shape, but other shapes are truncated or clipped in strange ways.

For instance, this original svg is simple:

energy node

But then when I import it into blender using the above method I get this:

enter image description here

Another one I have is even more strange. Original:

enter image description here

But then in blender using import svg and extrusion:

enter image description here

Would love to know what I am doing wrong here! I have gone over both articles several times and not really sure what else to try.

Thanks!

EDIT: Here are the svg files for reference -

http://elephantlaboratories.com/svg/sol-energy-node.svg

http://elephantlaboratories.com/svg/sol-transmit-tower.svg

$\endgroup$
  • $\begingroup$ What blender version are you using? I can't seem to recreate your error, importing these files works fine with my blender 2.73 at home. The object is initially tiny, but when scaled x1000 is fine. I thought this might be related to the fact these files are exported from illustrator, but I opened and re-saved them through inkscape, which generates more orderly and explicit SVG, and it made no difference on the end result. $\endgroup$ – TLousky Aug 18 '15 at 6:09
  • $\begingroup$ I am using blender 2.71... I will try to update blender and let you know. $\endgroup$ – prismofeverything Aug 18 '15 at 6:18
  • $\begingroup$ works here.. after first scaling it up.. and applying the scale, then extrude by a really small amount.. i.stack.imgur.com/usqgW.png $\endgroup$ – zeffii Aug 18 '15 at 6:51
  • $\begingroup$ This is due to precision errors of un-applied scale. See blender.stackexchange.com/q/8654/599 $\endgroup$ – gandalf3 Aug 18 '15 at 6:55
  • $\begingroup$ Related: blender.stackexchange.com/a/23106/599 $\endgroup$ – gandalf3 Aug 18 '15 at 6:55
7
$\begingroup$

This sort of thing can happen when your object has a very extreme scale.

To fix it, apply the scale with ⎈ CtrlA> Apply Scale.

enter image description here

When you scale an object in object mode the mesh data is not changed, but it will be distorted according to the scale in a non-destructive way (like a modifier). Since your object was scaled up by such a huge amount, it caused some distortion; probably due to precision error.

$\endgroup$
6
$\begingroup$

I'd like to point out here that the right way to do this is to be aware of the output scale settings in your Vector Graphics application. While the problem here isn't Blender, it is a reoccurring question and I feel it's worth explaining.

In the case of Inkscape it's easy to set the document properties to Meters as it comes closest to the Blender's default grid dimensions.

  • In Inkscape: File -> Document properties and set it to Meters.

See here, the inkscape scale is represented in M. (but you need to choose that from the drop-down seperately to see it in the Inkscape Viewport)

enter image description here

If you do that right, there's no need to rescale / apply. The SVG should import at the right size.

$\endgroup$

protected by cegaton Jan 17 '18 at 22:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.