6
$\begingroup$

I have "double-sided" unchecked/disabled, but the backs of my faces still render anyway. I should be able to create a cube, flip normals, and render an inside out cube but it doesn't. How can I make it so faces do not show up in neither the viewport nor the render? enter image description here

I've found that in 2.4 I could do this with an option called "No v.normal flip" which supposedly prevented the render from automatically flipping normals to face the camera. It would seem now blender still does that but there's nothing I can do about it.

$\endgroup$
5
  • 4
    $\begingroup$ Which render engine are you using? $\endgroup$
    – gandalf3
    Aug 17, 2015 at 22:20
  • 1
    $\begingroup$ I believe what you're talking about with "No v.normal flip" is now done using the "Backface Culling" option. This is found in the Properties Panel under Shading > Backface Culling. Any faces with inverted normals will then show as transparent. But this is only for the Viewport. If you want to render this way I think you'll need to make a custom material in Cycles. (This assumes you're using Cycles) I can post this as an answer with more details, but first of all I'd like to know: is this the kind of effect you're going for? I wasn't totally sure what you meant by "inside-out cube". $\endgroup$
    – Mentalist
    Aug 18, 2015 at 2:41
  • $\begingroup$ I've decided to go ahead and post an answer for now, and I will add more to it later. I wanted to show you some images first of all to explain what I meant. $\endgroup$
    – Mentalist
    Aug 18, 2015 at 3:12
  • $\begingroup$ Hi! I am using the Cycles render, but I would expect to be able to do this with any render engine. I feel this is a huge short-coming of Blender to not be able to simply render only faces facing the camera. What I mean by "inside-out cube" is that no matter what angle you view it, you always see the inside of the walls furthest from you. $\endgroup$
    – Ben Mora
    Aug 19, 2015 at 13:32
  • $\begingroup$ The specific application I am going for is making photo-real glass. You can't just make a glass surface. Light needs to refract when going into the object AND when going out, BUT going out has to be a different IOR than when it went in. (Through glass, and then through air.) What I do is duplicate the object, invert the faces, and give the duplicate an "Air" material/shader. Since Blender renders both sides of a face, this can't be done. That said, I will try your solution and let you know if that does what I need. Thank you so much for your help and comments! :) $\endgroup$
    – Ben Mora
    Aug 19, 2015 at 13:35

1 Answer 1

6
$\begingroup$

How to make backfaces transparent

For the Viewport

Enable the "Backface Culling" option. This is found in the Properties Panel under Shading > Backface Culling. The backfaces will then show as transparent in the viewport.

Enabling Backface Culling in the Viewport

For Cycles Materials

Connect the Geometry node's "Backfacing" output to the "Fac" input of a Mix Shader. Then plug a Transparency Shader to the bottom input of the Mix Shader and your visible shader(s) into the top one. In this way you can factor between your visible material and transparency, or any other type of material for that matter.

A Cycles material with transparent backfaces

With newer versions

Today you'll want to multiply the Backfacing output of the Geometry node with the Is Camera Ray output of the Light Path node. This effectively creates a conjunctive relationship between the two properties, i.e. IF Backfacing AND Is Camera Ray THEN render solidly. Otherwise the cube will appear black. This is because when a light ray tries to bounce back into the camera from the inside of the cube, it will have to pass another back facing face, which will then of course be treated as solid material. Adding an extra condition of having the ray originate from the camera makes backfaces transparent if they don't come from the camera, allowing rays to pass through the object when bouncing back

A more modern Cycles material with transparent backfaces

$\endgroup$
3
  • $\begingroup$ @Keheck Good thoughts, nicely explained. Thanks :) $\endgroup$
    – Robin Betts
    Mar 24 at 17:45
  • $\begingroup$ My apologies for accepting this answer nearly a decade later! Thank you! $\endgroup$
    – Ben Mora
    Apr 23 at 22:17
  • $\begingroup$ @BenMora No worries - better late than never. Thanks for accepting! :-) $\endgroup$
    – Mentalist
    Apr 25 at 1:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .