1
$\begingroup$

I have set up some fire in my scene, using a domain with a custom material, an object whose flow is set to 0, etc. Basically, when rendering in the view port it works fine. But when I click the "animate" button to make my image sequence, no fire shows up.

It's not very convenient for me to upload my .blend file, so I would just like a list of the possible solutions.

I'm using the newest version of blender as of this post (I believe it's 2.74a).

Here is my node setup: enter image description here

SOLUTION

As per the comment below, the Transparent setting in the film tab of the render settings was the problem.

$\endgroup$
6
  • $\begingroup$ Can you at least share an image of the node tree for the fire/smoke domain? $\endgroup$
    – user1853
    Aug 17, 2015 at 6:16
  • $\begingroup$ @cegaton added to question $\endgroup$ Aug 17, 2015 at 6:29
  • 1
    $\begingroup$ Are you perhaps rendering with Transparent Film enabled? See blender.stackexchange.com/q/32900/599 $\endgroup$
    – gandalf3
    Aug 17, 2015 at 7:19
  • 1
    $\begingroup$ Well, there is of course the classical case: your smoke cache (Have you baked the smoke? If not, that could be it.) starts at eg. frame 0 and your animation at frame 1. When you render a single frame, you load the cache for that frame and all is well. When you render an animation, you start at frame 1. When the render starts at frame 1, the smoke cache doesn't get loaded. Because of this, the smoke doesn't appear. $\endgroup$
    – Mörkö
    Aug 17, 2015 at 7:40
  • 1
    $\begingroup$ Are you rendering with CPU or GPU? If its the GPU try the CPU... $\endgroup$
    – PEAR
    Aug 17, 2015 at 11:53

0

Browse other questions tagged .