3
$\begingroup$

So I've been using WoW model viewer to export .obj files into blender. Everything works great up to the point where a UV texture that's created by WoW model viewer has any transparency on it. In the UV map this is shown as a black area, and looks terrible on the model itself.

After looking it up on Google I found an archived post in regards to the alpha is the black area, however I don't understand how this translates and the post itself had images that were broken links, I've still yet to find anything on Google close to this archived post.

Just starting up with Blender I am struggling to find where to resolve this transparency issue, as it's making certain models look terrible.

$\endgroup$
1
  • $\begingroup$ Are you talking about the model in the 3D view, or rendered. And if rendered cycles or blender internal? $\endgroup$
    – David
    Aug 17, 2015 at 2:13

2 Answers 2

5
$\begingroup$

You have to make the following Node set up: Connect 'Mix Shader' node in the 'Material Output', then use as your first shader 'Diffuse' and plug in it your 'Image Texture' node, now connect 'Transparency' Shader as the second shader, and finally to the factor connect your 'Image Texture' once more.

enter image description here

$\endgroup$
3
  • 2
    $\begingroup$ If this don't work try to plug the Diffuse shader on the bottom and transparency in the middle $\endgroup$
    – A.D.
    Aug 17, 2015 at 5:58
  • 2
    $\begingroup$ Seems the correct way is to have the transparency in the top shader input. Thanks for this! $\endgroup$ Aug 17, 2015 at 9:21
  • 1
    $\begingroup$ I ended up using the Alpha output from the top Image Texture node for the Mix Shader node Factor input. Also, as @NeilAshleyHickman said, use the top Shader input of Mix Shader node for the Transparency BSDF node $\endgroup$
    – gatzkerob
    Nov 23, 2018 at 6:13
0
$\begingroup$

So, as @NeilAshleyHickman and @gatzkerob answer. Here is the way:

  1. Create material, then select Mix Shader in Surface section
  2. Set the first Shader to Transparent BSDF, and the second to Diffuse BSDF
  3. Click the right dot button in Color and select Image Texture, then select your transparent texture image.
  4. Goto Node Editor window (Shift + F3), and connect the Alpha port of Image Texture to the Fax port of Mix Shader.

(I got a problem setting eyebrow and hair material, then it solved)

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.