5
$\begingroup$

render composited preloaded external image sequence without 3D scene

Does anybody have a solution in form of script, some addon or some 'hack' how to render only composited image sequences and passes that you have loaded in Compositing Nodes?

Blender doesn't do that directly because blender firstly render 3D scene (even 3d scene is empty) and then shortly produce render image for current frame from Compositing Nodes...

As you know blender Compositing can be awesome, I want use it like Nuke, but this is barrier for fast using in sense of speed-up post-processing.

$\endgroup$
  • 2
    $\begingroup$ If you mean directly render only images (from Image node) that you process using Compositing nodes (and the whole scene isn't important for you), then the solution might be deleting Render Layers node and plugging only Image node with the desired image. $\endgroup$ – Mr Zak Aug 16 '15 at 19:18
  • $\begingroup$ That's strange, if there are no renderlayer nodes in your compositing setup, blender shouldn't be rendering the scene. Is it possible you could upload your .blend? $\endgroup$ – gandalf3 Aug 16 '15 at 23:52
  • $\begingroup$ Just add a composite node. Try making a new file and copying your stuff over to it with append then, re-render. $\endgroup$ – John Roper Aug 17 '15 at 1:04
1
$\begingroup$

Are you sure it does really render the empty scene (maybe add some meshes and lights to test this)?

If you only have file output nodes and no composite output blender will show an empty render image when finished with the compositing since it got nothing to show from your node pipeline. So just add a composite node as output to your node setup like John Roper said ...

$\endgroup$
  • $\begingroup$ If you are right, it would give us composited images to output directory much more faster ! Yes I am 100% sure blender first look 3d scene and then calculate composite image because you cannot disable every render layer, at least one render layer must be enabled.... link[link] View image on this link... $\endgroup$ – Jovica Šalović Aug 17 '15 at 11:36
  • 1
    $\begingroup$ Dont mix up render layers with render layer input node ... Yes one render layer had to be enabled but in your composite nodes should be no render layer input node. $\endgroup$ – ronald8 Aug 17 '15 at 12:32
0
$\begingroup$

Make sure you scene has a camera in it. You don't need anything else, but you MUST have a camera. Then either do a regular render and just immediately cancel it, or do an OpenGL render (both available via the main Render Menu, or various buttons at the bottom of the UI.) Then unplug and replug your image into the Composite node.

$\endgroup$
  • $\begingroup$ Listen, I dont need blender to render scene ! I want to immediately have rendered image from composite! Rendering of empty scene is too longer than second phase: outputing composited image for current frame ! Just look at the image I posted up there... $\endgroup$ – Jovica Šalović Aug 16 '15 at 20:08
  • 1
    $\begingroup$ It should be possible to write a script or addon for this, but it doesn't seem to exist yet (at least I couldn't find one quickly on google). At the moment, you need to have initialized a render. This takes like half a second, so I'm not sure what the problem is. $\endgroup$ – Drudge Aug 16 '15 at 22:13
  • 1
    $\begingroup$ @Drudge Half a second per frame adds up when rendering animations $\endgroup$ – gandalf3 Aug 16 '15 at 23:53
  • $\begingroup$ @gandalf3 It's not half a second per frame. It's half a second per session when opening your file and wanting to get the compositor to show an image loaded from a file. $\endgroup$ – Drudge Aug 17 '15 at 0:26
  • $\begingroup$ @Drudge In that case, all you should need to do is change frame or ctrl+shift click on the last node. Not sure why this isn't working in the OP's case? $\endgroup$ – gandalf3 Aug 17 '15 at 0:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.