8
$\begingroup$

I have recently installed the latest stable version of blender (2.75a) and used the video editor to join audio with a video. The problem is, when I click Anim to render the video, it generates a video file but with no audio at all. As I have seen in many tutorials, all I need to do is to set the renderer's audio settings properly in scene's "encoding" tab... it should be found under the "output" tab, but it just does not exist! What I see is exactly this: OpenSUSE - Blender cannot encode or export video

I have searched in many sites over the web and tried many "possible" solutions with no luck at all. I have checked the FPS settings, reinstalled and even installed previous versions of blender (2.6) and still nothing.

I just want to get what I have made in my blender's project written in a video file, just that... Thank you for your help

$\endgroup$
  • $\begingroup$ What file format are you exporting to? $\endgroup$ – Carlo Aug 14 '15 at 8:53
  • $\begingroup$ AVI Raw format. $\endgroup$ – Mr. Poronga Aug 14 '15 at 9:25
  • $\begingroup$ Do you have an audio device selected in "user preferences" > "system" tab? $\endgroup$ – Polosson Aug 14 '15 at 9:34
  • $\begingroup$ Are the Encoding options visible in the H.264 output file format? $\endgroup$ – Carlo Aug 14 '15 at 10:03
  • 1
    $\begingroup$ AVI Raw is only a container for raw frames, does not support audio. $\endgroup$ – Jaroslav Jerryno Novotny Aug 14 '15 at 10:34
8
$\begingroup$

I don't think that AVI Raw has encoding options.

As it's an uncompressed format you'll not have much setting to work with, they are just plain frames.

The purpose of this format is to provide an input video that will be mixed and encoded with sync audio in a second phase, after for example some compositing, or color correction. It's the RAW data, it is expected to be used as a "base", not to be the final result.

You can Mixdown to extract audio from your file and than mix them with video in Blender or an external application.

Note: I wasn't able to find out any evidence of the fact that Blender AVI Raw format, despite its name, is not able to contain audio (and I'm not even sure), so consider this as a personal opinion.

You should use another output format.

$\endgroup$
  • $\begingroup$ Thank you all very much for your help, It was the AVI Raw format that does not support audio, as you have stated. I've switched the format to another and now I can see the encoding tab, I can't believe that was the problem. $\endgroup$ – Mr. Poronga Aug 19 '15 at 16:57
0
$\begingroup$

I thought I had lost Encoding Panel Tab, and was searching long time in internet, but, at the end, i dont know how, I had move it to the bottom of all the Tabs. I was accostumed to see it below Output Tab, so I was happy when I found the Panel at the bottom of all.

$\endgroup$

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.