0
$\begingroup$

in addition to my other question, I have another problem with the Video Sequence Editor in Blender.

I am editing a screen capture, where I need to identify that one frame in which a window disappears. I found the correct frame and cut the clip. Afterwards, I searched for that frame again. When I approach the frame in which the window disappears from the left, frame number 1044 is the very first frame, in which the window is gone. I would expect that if I go one single frame left, the window would appear again. But in fact, it doesn't. I have to go left until I reach frame 1040, which is then the very first frame, in which the window appears again.

So in summary, I am unable to find the right frame for separating the screen capture as it makes a difference whether I am approaching it from the left or right.

Do you consider this a bug? And if not: Could anyone tell me how to get rid of this "feature"?

I am using Blender v2.75 on a Win7 system.


I tried to follow 3pointedit's instructions and it seems to reveal a problem with the screen capture clip. I started a complete new Blender-project and added the screen capture as a movie. Then, I did "Rebuild Proxy and Timecode Indices" with the settings attached. Unfortunately, Blender crashes immediately without any error message, it just exits.

I tried the same with one of the GoPro clips and it works perfectly (same settings).

So obviously, there is something wrong with the screen capture clip...

Rebuild Proxy and Timecode Indices Settings

$\endgroup$
  • $\begingroup$ This make me think that your imput video, though it appear to be 29fps (blender.stackexchange.com/questions/35695/…), maybe is not. I had similar problem and I solved by re-encoding the imput video to "trusted 29fps" with an external application. $\endgroup$ – Carlo Aug 14 '15 at 8:34
  • $\begingroup$ Do you have the same issue also with other imput files? $\endgroup$ – Carlo Aug 14 '15 at 8:40
  • $\begingroup$ That's due to decoding problems with the internally used ffmpeg library. Here's a workaround to receive the best possible accurate frames out of your footage: blender.stackexchange.com/a/49219/2843 $\endgroup$ – Samoth Mar 21 '16 at 19:40
1
$\begingroup$

You can also generate a timecode file for the clip (it lives in the proxy panel of strip properties), when creating the TC you can choose to NOT render a proxy. The playback of media should be much better. But transcoding to a more simple codec is best (less compression, more real frames).

| improve this answer | |
$\endgroup$
0
$\begingroup$

My guess is that you are dealing with an MPEG, AVCHD or similar compressed video file that is not using an Intra-Frame compression scheme, but is using Inter-frame. Inter-Frame is not great for editing because it does not contain the information for each frame but has certain keyframes and delta frames that only record he changes from the prevous keyframe. (read this: http://www.pcmag.com/encyclopedia/term/45144/interframe-coding).

Sometimes (I know this from motion tracking footage) the direction in which the stream is read will make a difference and will yield errors.

To correct this you'd need to transcode your source to an image sequence, or a codec that is using intra-frame (unique frames)

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.