4
$\begingroup$

Rigify rig main properties and rig layers disappeared in N panel

so, the worse part, is cannot switch from IK and FK... how can I restore it and if I cannot, how can switch from IK and FK without the Rig Properties tab?

Thanks

$\endgroup$
4
$\begingroup$

Open a Text Editor and see if there is rig_ui.py file there.

  • If there is click Run Script and check also Register. Your controls in N panel should reappear. Also make sure for future that you have Auto Run Python Scripts enabled in User Preferences under File tab (so the registered scripts are run automatically when you open blend file).

  • If you linked the rig into a new file, look in the original file if there is one. Both the rig and it's script need to be linked.

  • If there is none script to find anywhere, you need to make a new one. Create another blend file, create some rigify rig there and copy the script.

    There is however a complication, each Rigify generated rig has a unique id, that matches with the script file, so the script we took will have some new random id and won't work with the original rig. Making these codes to match solves it:

    enter image description here

$\endgroup$
  • $\begingroup$ Additional info: this happened to me when I linked in the rig from another file. The solution was to link rig_ui.py from the same file, then proceed as above. $\endgroup$ – Jabberwock Jul 2 '16 at 1:43
  • $\begingroup$ in general it's recommended to change the <i>rig_ui.py</i> file name after rigify generates the rig (or even beforehand in rigify advanced settings), specially if you're going to use multiple characters in the same file. $\endgroup$ – Ahmed Ali Apr 23 '18 at 13:00
  • $\begingroup$ @AhmedAli the script name has no power here, it's all in the id codes. I edited the answer, it was incomplete. When these id codes break (multiple characters or not), not even the nicest script names will help.. But I agree that naming things nicely should go as common sense to organize things. $\endgroup$ – Jaroslav Jerryno Novotny Apr 23 '18 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.