6
$\begingroup$

In Blender 2.75a, I'm making a render using Cycles and the Freestyle pass. My scene contains a mesh with a smoke modifier that I'm rendering through a volumetric shader.

The boundaries of this mesh (the box, in the example below) are meaningless to the extents of the render, therefore the mesh should neither have its edges drawn by freestyle nor cover the lines of the things behind or inside it.

I don't know if it's possible to tell freestyle to completely ignore the mesh, and how to do it.

This is what happens if I render a sample scene with cycles+freestyle+volumetric rendering and without further options (left) and with the box assigned to an excluded object group (right)

result

Neither of them is the expected result: I'd like to have the freestyle lines on the sphere but not on the box. Is it possible?


Add after TLousky answer

As you can see, even if I choose to render freestyle all the objects except the box using an "Inclusive" group, the "phantom" of the box still covers the edges of the sphere and partially of the cone and torus (exactly as in the example above where I used an Exclusive group containing only the cube instead) enter image description here

$\endgroup$
  • 1
    $\begingroup$ You may have to render the smoke on a separate renderlayer and combine in the compositor $\endgroup$ – gandalf3 Aug 13 '15 at 21:29
  • $\begingroup$ In the actual scene that I'm rendering the smoke is not (always) in the foreground, so it'd be tricky to add it on a renderlayer on top of all the others. I was wondering whether a more straightforward solution existed; otherwise I'll have to learn to use renderlayers well! $\endgroup$ – Nicola Sap Aug 13 '15 at 21:44
6
$\begingroup$

The source of the problem is that Freestyle view map has (can see) the smoke domain geometry. This is a typical problem. Transparent mesh like glasses can be solved with the same method.

  1. Put torus, cone and sphere on a new render layer (mesh on layer 1). This render layer will be rendered with freestyle.

  2. Isolate the smoke domain cube to another render layer (ie: mesh on layer 2). Turn off freestyle on this render layer or don't render this layer at all.

That should solve the smoke domain cube from being rendered.

$\endgroup$
  • 1
    $\begingroup$ i recently had this problem too. this was also the only way i could figure out doing this. would be too nice if freestyle actually recognized the opacity of the final smoke and not the domain. $\endgroup$ – blackdot Sep 18 '15 at 8:37
2
$\begingroup$

You can control which edges are visible and which aren't if you mark the edges you want to display via the edge menu (Ctrl + E in edit mode), and change the freestyle settings to display only marked edges (see image below).

Freestyle Settings

If you can't or don't want to mark the edges of the objects you want to render in freestyle, you can simply use the group selection method. Objects included in the group will be rendered in the freestyle pass, while the rest won't:

Group selection in Freestyle

$\endgroup$
  • $\begingroup$ What you say is true, but it doesn't apply to my case (see added picture): not only I do want to "hide" the cube edges, but I also need to re-enable the edges of the objects behind and inside it. $\endgroup$ – Nicola Sap Aug 13 '15 at 21:28
  • $\begingroup$ That's weird, when I tried it on a similar scene it seems to behave as expected: picpaste.com/pics/FreeStyle3-kFLInRSa.1439501984.jpg $\endgroup$ – TLousky Aug 13 '15 at 21:40
  • $\begingroup$ Not if you use "visibility" - and of course I don't want to see the edges of the portion of the torus which isn't actually shown. $\endgroup$ – Nicola Sap Aug 13 '15 at 21:47
  • $\begingroup$ Expected result $\endgroup$ – Nicola Sap Aug 13 '15 at 21:54
  • $\begingroup$ (Just to clarify: the "expected result" above is a picture I made by hand in GIMP to better explain my point. It's not the proof that the answer works for me) $\endgroup$ – Nicola Sap Aug 14 '15 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.