This is the object that has a value of UVMap.

This picture has a value of UVTex.

Whenever I try to join the objects together, the UV Map is entirely messed up, to the point where all of my objects' faces are one vertex. Should I not join the two right now, and do it later, or should I find a way to get the value to be the same for both. If someone could give me some advice as to what to do here, that'd be great. Thanks! (I use cycles render.)

  • $\begingroup$ To clarify, you want to join two UV maps into one UV map? $\endgroup$ – gandalf3 Aug 13 '15 at 19:06
  • $\begingroup$ Essentially, yes. However, whenever I do the UV map that has a value of UVTex turns into one vertex on the map, should I try and unwrap those specific objects and redo the map? Edit: So i just tried that actually, and that allows me to redo the objects that are messed up. if I have nothing else I can do to save the other map, I can most certainly redo them. Thanks. $\endgroup$ – Alexcz Aug 13 '15 at 19:17
  • $\begingroup$ try to rename UVTex as UVMap, then join $\endgroup$ – Bithur Aug 13 '15 at 19:41
  • $\begingroup$ I tried doing that, but it won't let me rename anything there. $\endgroup$ – Alexcz Aug 13 '15 at 19:50

I had this issue before. Rename both UV maps (on the mesh properties panel) to have the same name, then join (ctrl+j) the meshes and both UV maps should be preserved.

| improve this answer | |
  • $\begingroup$ @Alexcz if you can't rename maps from properties panel/data tab, then you should upload your blend file $\endgroup$ – Bithur Aug 13 '15 at 20:16
  • $\begingroup$ This did indeed work, I went to the mesh properties panel and renamed it, and they joined up no problem. This saved me about 3 hours of UV mapping again, so I must thank you. $\endgroup$ – Alexcz Aug 13 '15 at 20:31
  • $\begingroup$ Any time. It is a strange behaviour and probably joining the meshes should preserve the UV data as 2 separate UV maps. Could be considered a bug. $\endgroup$ – beiller Aug 13 '15 at 20:39
  • $\begingroup$ I'd have to agree, at first I didn't understand what you were saying when renaming the two meshes, so I tried that, and it didn't work, once you mentioned the properties panel, I got it to work instantly. ^^ At least this bug wasn't too bad, it would've been somewhat of an inconvenience if I had to re-do some work, but in the end, it was solved. $\endgroup$ – Alexcz Aug 13 '15 at 20:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.