1
$\begingroup$

The Archimesh add-ons don't appear in the add-ons list after installing them. I got this message: 'One or more addons do not have UTF-8 encoding!

$\endgroup$
  • $\begingroup$ It worked for me. I extracted the zip and copied the resulting directory to 2.68/scripts/addons/. How did you install them? $\endgroup$ – gandalf3 Oct 29 '13 at 17:34
  • 1
    $\begingroup$ Voting to close, this is a bug report in Archimesh - Scripts need to use UTF8 encoding, if they don't - this error will be reported. $\endgroup$ – ideasman42 Oct 30 '13 at 0:14
3
$\begingroup$

seems like this has been solved on the thread

http://blenderartists.org/forum/showthread.php?315980-Archimesh-Architecture-elements-%28rooms-doors-columns-stairs-tile-roofs%29/page2

when you go to the github link https://github.com/Antonioya/blender/tree/master/archimesh

Raw button on Github

you need to click on the zip file then select raw and it will download correctly.

| improve this answer | |
$\endgroup$
1
$\begingroup$

It sounds like you extracted the zip and installed each .py file individually.

Try directly installing the zip instead:

Addons can be python scripts .py or .zip files (containing .py scripts).

  1. Press Install from file in CtrlAltU> User Preferences > Addons:

    Install from file screenshot

  2. Navigate to the zip and select it:

    enter image description here

  3. Enable the addon:

    enter image description here

If you want to install it manually, you can:

  1. Extract the zip

  2. Copy the resulting directory containing the .py files into your //scripts/addons/ directory (// being the path to your blender config directory). See the wiki on file locations for more info on where this is:

  • Windows 7: C:\Users\%username%\AppData\Roaming\Blender Foundation\Blender\2.5x\scripts\addons

  • Windows XP: C:\Documents and Settings\%username%\Application Data\Blender Foundation\Blender\2.6x\scripts\addons

  • Linux: /home/$user/.config/blender/$version/scripts/addons

There is also a system wide location for the configuration directory, see the wiki for more details:

Blender can be installed system wide or run from an extracted bundled with all necessary files contained.

There are 3 different directories blender may use, their exact locations are operating system dependent.

LOCAL: location of configuration and runtime data (for self contained bundle)
USER: location of configuration files (normally in the user’s home directory).
SYSTEM: location of runtime data for system wide installation (may be read-only).

Note that the the path to offending files will be printed to the console:

enter image description here

To convert encoding to UTF-8 you can open the offending .py file in a text editor and resave with UTF-8 encoding selected.

| improve this answer | |
$\endgroup$
  • $\begingroup$ While the is a comprehensive answer, its more generic documentation on howto install any addon and doesn't address the error asked in the question. $\endgroup$ – ideasman42 Oct 30 '13 at 0:16
  • 1
    $\begingroup$ @ideasman42 I figured the OP might have done something wrong when installing the addon because it worked fine for me out of the box. (I was able to reproduce the error by installing each .py file in the zipped directory separately) $\endgroup$ – gandalf3 Oct 30 '13 at 1:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.