2
$\begingroup$

I model in millimeters inside Blender, for 3D printing. Every time I want to Export STL, I have to untick Scene Units and change the Scale to 10.0. These settings aren't remembered.

Blender config for 3D printing

How do I save them as defaults?

$\endgroup$
2
$\begingroup$

Solution

Manually

  1. To remember unit settings make your adjustments then File > Save Startup File (Ctrl-U)

  2. To change STL Export defaults navigate to
    C:\Program Files\Blender Foundation\Blender\2.74\scripts\addons\io_mesh_stl
    and open the __init__.py file.

    global_scale is at __init__.py#L166, change default=1.0 to 10.0

    use_scene_unit is below at __init__.py#L172, change default=True to False

Windows PowerShell Script

Configure Blender STL Export default settings - GitHub Gist

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.