1
$\begingroup$

I am trying to model a wine glass with the spin tool. But the result looks more like a cup/beaker than a wine glass.wine glass

It is my understanding that the spin tool uses the 3D cursor as the pivot point. Not sure what I do wrong. The blender file is here

$\endgroup$
  • $\begingroup$ Related answer: blender.stackexchange.com/questions/24496/… $\endgroup$ – Paul Gonet Aug 11 '15 at 9:43
  • 1
    $\begingroup$ Drinking glasses rarely have an even thickness, therefor you model the profile and thickness and spin it around. There exist comprehensive answers related to this process, it's not a bad question.. but it has been answered before. $\endgroup$ – zeffii Aug 11 '15 at 9:51
0
$\begingroup$

You could also click on the vertex you want the object to spin around. Then SHIFT + S --> cursor to selected. And then use the spin tool

$\endgroup$
6
$\begingroup$

It is pretty simple. If you look at your scene from upwards you see it well:

Offsetted cros section

Your silhuette / cross section / whatever you want to call it is offsetted on the Y axis. As spin pivots around the 3D cursor, you want it to look like this instead:

Centered cross section

Now the results are as follows:

Corrected result

Also, for practicality's sake, I would encourage you to look into the screw modifier. It does the same thing as spin, but you can edit you cross section in real time. (These settings seem to work the best with your scene.)

Screw modifier

Also, you have duplicate vertexes (the one selected, the second and third ones from up and the one at the boundary between the foot and the upper part of the glass). You can spot them when they break smoothing and by looking at the surrounding edges. If you select only one of the pair of vertexes as shown below, the edge starting from the other one (here the edge that goes down) doesen't get a gradient.

Glitches with double vertex smoothing

They can do all kinds of evil (though they may sometimes be used to guide subdivision). If you try smoothing the mesh in this scene, it looks weird. You can fix this by selecting all vertexes and doing W > Remove doubles. It looks like this when fixed:

Removed double vertex

I hope this helped.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.