5
$\begingroup$

I've a character that's draped with a piece of cloth along it's waist and it runs down along the leg as well. That is, the legs of the character are loosely (not tight fitting) , but entirely covered by some garment. I have fit a rig to the character and did the skinning by parenting the character to the armature. So now when I move the armature the corresponding limbs of the character also moves , as expected (in Pose mode). But the legs of the character penetrate through the cloth when the legs are moved.
I want the rigging such that the cloth is also part of the system. When the legs are moved, they should push the covering garment, and not penetrate through it, or tear it. The character has a Collision modifier already added to it, and the garment has a cloth modifier. How do I do the rigging with the character's clothes on?

$\endgroup$
  • $\begingroup$ put the cloth modifier under the armature modifier, setup your keyframes on the rig and simulate the cloth. $\endgroup$ – Jaroslav Jerryno Novotny Aug 10 '15 at 18:05
2
$\begingroup$

There is a function to copy vertex groups to non-matching meshes. It is great for automatically skinning clothing on characters.

First select the character mesh, then shift + select the clothing. Press spacebar and type "transfer weights". An operator should show up. This seems to be broken in the latest blender 2.74+ but try 2.73. (I just tried on a copy of 2.71 I have laying around and it works well).

The new versions have "Transfer mesh data" but it does not seem to work for me.

Cheers!

$\endgroup$
  • $\begingroup$ I did the weight transfer thing, but additionally what was required was to parent the cloth as well to the armature. Do add that to your answer..Thanks! $\endgroup$ – sanjeev mk Aug 11 '15 at 10:51
  • $\begingroup$ I will add that I figured out how to use this function in newer blender versions. Select the source mesh. Select the destination mesh. Go into weight paint mode, and on the left side "drawer" there is a transfer weights function. Seemed to work after mucking around with it for awhile. $\endgroup$ – beiller Aug 12 '15 at 15:13
1
$\begingroup$

The "transfer weights" totally workes.. it is in the newer versions also but in a different place..

enter image description here

1- Parent the cloth to the armature

2- Select the Character mesh then Shift+ select the cloth

3-do as in picture.. (from "Weight Paint" ,, select "Weights" in the 3D view header.. then Select"Transfer Weights")

That should do it.....

$\endgroup$
  • $\begingroup$ Parent the cloth to the armature with which option? I tried with Armature Deform with Empty Groups, but nothing works :( Using 2.78 $\endgroup$ – modernator May 24 '17 at 16:20
  • $\begingroup$ followed all the instructions and now it seems to only be following one bone which is the one i think i parented to while the armature was in object mode. Regardless this did not work $\endgroup$ – A guest May 25 '17 at 0:28
0
$\begingroup$

I tried 2.76 and never worked. I sent a bug report and nothing. It was closed as invalid. Ha. So I uninstalled 2.76 and got 2.73 from http://archive.blender.org/download/get-blender/older-versions/index.html. It worked right away following tutorial https://www.youtube.com/watch?v=WVfTRwXpmuQ. Went back into Pose mode and cloth moved with rig. The robe needed some adjustment, but it worked!!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.