2
$\begingroup$

I want to give my model a glare effect at robots eye,

enter image description here

so I gave the material assigned to the eye Pass Index of 1

enter image description here

then when I went to compositor and made this node set up,

enter image description here

in the viewer I could not see anything like that, (BW Image)

enter image description here

$\endgroup$
  • 1
    $\begingroup$ could you upload the blendfile? $\endgroup$ – gladys Aug 10 '15 at 9:01
2
$\begingroup$

This is pretty weird. I can think of three possible workarouds:

  • Render the eye as a separate object, then use Object Index.
  • Render the eye on a separate RenderLayer.
  • As the eye seems to be pretty much an emission material, you could separate the emission pass.
$\endgroup$
4
$\begingroup$

Your setup seems to be correct.

The material you want to use as mask must have an Pass Index number.

enter image description here

In the render layers enable Material Index

enter image description here

Now press F12: YOU HAVE TO RENDER THE IMAGE for this changes to update, and the compositor has the proper information to work with (Sounds simple, but this step is sometimes overlooked).

After that, the node setup could be something like this, where the ID mask index matches the index set for the eye material and is used as a mask for further transformations:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.