3
$\begingroup$

I’m on an iMac with a Magic Mouse (no scroll wheel or RMB). I use RMB selection, via ⌘ command LMB. I have enabled Emulate 3 Button Mouse.

I'm trying to figure out how to select edge loops. The usual method is Alt LMB, so for me that would be Alt ⌘ Command LMB, but that does nothing.

I tried adding this preference (and tried all the mouse action types: Any, Press, etc.), but still nothing.

enter image description here

How can I select edge loops with Alt ⌘ Command LMB?

$\endgroup$
  • 3
    $\begingroup$ Blender is designed to work with a mouse with left, right and a middle (scroll) button . While it is possible to work around it it IMHO is a lot easier to get a cheap 3 button mouse and actually enjoy working on Blender the way it was desined to be used... $\endgroup$ – user1853 Aug 11 '15 at 4:10
  • 1
    $\begingroup$ here are some little helpers for the magic mouse, but totally agree with @cegaton $\endgroup$ – Dan Apr 14 '16 at 11:31
  • 1
    $\begingroup$ @cegaton I tried using a 3-button mouse, but it's hard to use with my physical disability. Would be much easier from an a11y perspective if I could figure out how to compensate using Alt Command LMB. $\endgroup$ – Aubrie Jul 2 '16 at 23:58
4
$\begingroup$

Figured it out! Whoo hoo. Turns out this is what I had to do:

enter image description here

  1. Select an edge (using CommandLMB)
  2. Open the Select menu.
  3. ControlLMB (right-click) "Edge Loops".
  4. Select "Add Shortcut".
  5. Press Alt Command LMB, which Blender interprets as Cmd Middle Mouse.

It seems that Alt LMB emulates the Middle Mouse Button. Not only that, mesh.loop_multi_select was the input I wanted, not mesh.loop_select, as I'd originally thought.

After I added that shortcut, this new input setting appeared in my user preferences:

enter image description here

All is not lost for Magic Mouse users.

$\endgroup$
  • $\begingroup$ can you tell me how did you configure your User Settings to have (Command LMB) instead of RMB. Just in case if you also know how to exchange MMB with something else would be a great Tip as well. I am starting with Blender and have a MacBook which I find super practical aside from the fact that I am starting to miss the middle and right button. $\endgroup$ – Dave Oct 3 '17 at 21:42
2
$\begingroup$

I was facing the same problem following this tutorial Model & Rig Pistons fast in Blender 2.8+. To select the edge loop it's said to use 'Shift alt click' but it doesn't work on my Mac. I made somme research on the internet and I arrived here but it doesn't help me.

After some tries, I figured that With Blender 2.8 when you have enabled Emulate 3 Button Mouse(Preferences > Input > activate Emulate 3 Button Mouse) you just have to double click on the edge to select the loop.

Hope this will help someone facing the same problem.

$\endgroup$
  • 1
    $\begingroup$ Hi, welcome. The question (4 years old) stated: "I have enabled Emulate 3 Button Mouse."...how is your late answer solving the issue or adding something useful? If it does, you could detail it a bit more... $\endgroup$ – m.ardito May 24 '20 at 9:21
  • $\begingroup$ @m.ardito clearly, the part in bold is the important part: once 3 button emulation is enabled, the short cut is not alt-click but just double-click. Who knows whether this was the answer 4 years ago, but it is now. It helped me. $\endgroup$ – Nathaniel Jul 12 '20 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.