10
$\begingroup$

Is it possible to hide a particle emitter object in the 3D view while keeping particles visible?
I know you can do this in the render with the Render Emitter setting, but this does not affect the viewport.

Sometimes the emitter can get in the way, though it's still useful to know where it is. The ideal solution then is to make it drawn as a wireframe, but setting the Maximum draw type to Wire or Bounds causes all the particles to be rendered as wireframes or bounding boxes too.

Setting the emitter object's draw type would work, except it also changes the way the particles for that emitter are drawn:

enter image description here enter image description here

Is there anyway to make particle emitters hidden or less distracting while keeping the actual particles unaffected (still rendered as solid or textured)?

$\endgroup$
  • $\begingroup$ if you are emitting from a mesh, could you not just change it visibility settings? $\endgroup$ – Vader Oct 26 '13 at 21:48
  • $\begingroup$ @JebediahKerman I assume you mean the settings in the outliner. The problem with that is it hides the particles as well. $\endgroup$ – gandalf3 Oct 26 '13 at 21:56
  • $\begingroup$ what about under the display options for the mesh. You could change type to Bounds $\endgroup$ – Vader Oct 26 '13 at 22:15
  • $\begingroup$ @JebediahKerman I already stated in my question why setting draw types doesn't work. Please see my edit. $\endgroup$ – gandalf3 Oct 26 '13 at 22:20
  • $\begingroup$ I think i found a way using the mask modifier $\endgroup$ – Vader Oct 26 '13 at 22:21
14
$\begingroup$

Another way (similar to Michal's answer) is to use a Mask modifier:

  1. Add an empty vertex group to the particle emitter by pressing the + button in Object Data > Vertex Groups:

    Add a vertex group

    Note that due to a bug in 2.69, you will need to assign and remove some geometry to the vertex group. Note that you must be in Edit mode to do this:

    enter image description here

  2. Add a mask modifier after the particle system with the empty vertex group:

    enter image description here

$\endgroup$
  • $\begingroup$ I was gonna post the same thing. $\endgroup$ – Vader Oct 26 '13 at 22:26
  • 3
    $\begingroup$ As of 2.77, you don't even need to create and assign a vertex group anymore. Just assign a mask modifier and leave it as is with nothing under "Vertex Group". It works for me, at least. $\endgroup$ – Highstaker Dec 31 '16 at 10:12
1
$\begingroup$

Create a bounding box around the emitter.

Add a boolean modifier to the emitter, set the mode to difference and chose the bounding box.

Ensure the particle system is applied before the boolean modifier (order in modifier stack)

Hide the bounding box.

Properties panel with emitter selected

$\endgroup$
  • $\begingroup$ Interesting solution, but it can get clunky with animated emitter objects. $\endgroup$ – gandalf3 Oct 27 '13 at 2:23
  • 1
    $\begingroup$ @gandalf3 well you could probably eliminate the clunk by parenting "Bounding box" as a child of "Cube" but it still adds unnecessary objects and computation time... if you have a 5M-tri mesh, I can't imagine that a Boolean modify would speed up your viewport. $\endgroup$ – wchargin Oct 27 '13 at 3:02
-2
$\begingroup$

In the object tab, set "maximum draw type" to "bounds". It won't be gone completely, but not really distracting and still selectable.

$\endgroup$
  • $\begingroup$ I have already stated both in the question and in this comment that setting the draw type of the emitter is not an ideal solution because it affects the particles too. I want the particles to remain unaffected, rendered as solid objects. $\endgroup$ – gandalf3 Oct 26 '13 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.