4
$\begingroup$

I've been creating a spaceship and I am now trying to set up the compositing nodes. For that, I am using pass indexes for materials, so I can change the effects in compositing nodes and i am having 3 different render layers: spaceship, afterburn and one more layer for slipstream.

I've been trying to place spaceship layer in front of afterburn so the glow effect of the afterburn would be exactly behind the spaceship and wouldn' t affect spaceship layer itself.

However, I can' t understand what I am doing wrong. Connecting two layers (spaceship and afterburn with glow effects) into mix shader's image sockets and spaceship's render layer alpha wire into the same mix shader's Fac input nothing happens. The spaceship layer doesn' t get placed in front of afterburn.

Here' s also an image for summarizing my problem. In other words, the glow of the afterburn affects the spaceship:

enter image description here

$\endgroup$
5
$\begingroup$

In render tab, film options just click "transparent" to get alpha

enter image description here

$\endgroup$
  • 5
    $\begingroup$ Think about accepting answers. blender.stackexchange.com/questions/35096/… $\endgroup$ – Bithur Aug 7 '15 at 12:24
  • 2
    $\begingroup$ Oh. Sorry for that and thanks for reminding. $\endgroup$ – TheLast_BlenderBender Aug 7 '15 at 14:50
  • $\begingroup$ Oh. another question, if I may. I added another scene that contains Earth to that project and added another render layer of the planet Earth into the same compositor as you can see in the previous picture. However, I couldn' t find the "Film" option to check "Transparent" for the planet scene to use the alpha input. My question: how can I set the transparency for the Earth layer in seperate scene? $\endgroup$ – TheLast_BlenderBender Aug 7 '15 at 15:04
  • $\begingroup$ Here' s the source file again. Don' t mind the crappy space picture though.. <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=402" /> $\endgroup$ – TheLast_BlenderBender Aug 7 '15 at 15:07
  • $\begingroup$ it's probably a blender internal scene. Go in render tab/Shading/Alpha:transparent $\endgroup$ – Bithur Aug 7 '15 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.