3
$\begingroup$

First, I'm a newb to tracking.

That said, I tracked my scene with a .3 solve rate. I dropped in a cube and rendered out a short animation... looked great.

I readjusted the position of my cube... nothing more... and now my track is broken.

All tracking points were locked, I did not resolve the scene... just suddenly my object is wobbling all over in the render.

Going back to my LOCKED tracking points, they are no longer staying put.

Anyone else seen this? Has happened on 2 machines, same reproduction steps. This last one was first time I tried locking the tracking points.

Memory issue?

Thanks...

Blend file

Original footage (40mb

$\endgroup$
  • $\begingroup$ very strange indeed. can you upload your blend file and the video in question? $\endgroup$ – cegaton Aug 6 '15 at 21:57
  • $\begingroup$ Blend and footage above. 1st render here: legacyoffun.com/download/stackexchange/blender/good-render.avi $\endgroup$ – Mike Mitrovich Aug 6 '15 at 22:17
  • $\begingroup$ is that the same clip? The tracked one is called 0014. None of the trackers match to the video clip the one you uploaded. $\endgroup$ – cegaton Aug 6 '15 at 22:24
  • $\begingroup$ Sorry for the confusion, renamed it when collecting files... 00014.MTS = Footage.MTS $\endgroup$ – Mike Mitrovich Aug 6 '15 at 22:26
  • $\begingroup$ did you alter the footage in any way? has it been edited? $\endgroup$ – cegaton Aug 6 '15 at 22:32
3
$\begingroup$

This looks like a bug, but here's a workaround:

As you open the file don't try to playback the scene or move a frame within the timeline. Instead switch to the Motion Tracking preset and in the the movieclip editor select your video clip and press P to cache or Prefetch the video clip.

enter image description here

enter image description here

On the bottom of the window you'll see a purple line indicating the prefetched frames.

enter image description here

Prefetching will load all of the frames into RAM and that will help you keep the trackers in place. The issue has to do with the video being in a delivery format (mts) in which the video is encoded using I, B, and P frames, which means that the information of a particular frame is not complete in every frame but is reconstructed using information from some preceding and subsequent frames. It's been optimized for playback using prediction vectors and crap like that. The sort story is that Blender needs to read the whole stream to have each frame land in the right place. For a more technical explanation read this

NOTE by default blender will only use 1GB of RAM to cache frames. You can change that number depending on the amount of memory on your system. To do that open the User prefences (CtrlAltU) and on the System tab you'll see the options for the prefetch and cache limits.

enter image description here

The other options you have to prevent this issue is to convert your MTS video file into an image sequence or a video file that uses intra-frame compression codec.

As I said this is likely a bug. You can report it.

$\endgroup$
  • $\begingroup$ Awesome, thanks for that! Doing more research along these lines and sounds like working with MTS is an issue with many editors, not just blender. Thanks for your help! $\endgroup$ – Mike Mitrovich Aug 7 '15 at 15:09
  • $\begingroup$ This is a bigger problem with long clips that can't be precached or prefetched completely. It's good to know, though, that converting it to the right format will help. $\endgroup$ – Matt Aug 12 '15 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.