1
$\begingroup$

I'm trying to create a simple animation for water in a stream. The idea is to have a repeating texture and then animate it's offset along the x so that over time the image scrolls to the right.

This partly works. While I can set the animation keys and while it does show the correct results when I render the image, there is no visual feedback in the 3DView when I play the timeline which makes it very difficult to tweak the animation.

Even worse, if I try to encapsulate this in an action, none of the keys that I set on the image offset show up in the action editor. I'd like to export this for a game which means that I need to have the keys in the action, but for some reason blender isn't doing this. (I can set keys for location, rotation etc of the object just fine. It's just the UV offset that isn't showing up there.)

enter image description here

$\endgroup$
  • $\begingroup$ Maybe try changing your viewport to GLSL shading since you're in Blender Game Engine. To get to the setting press "N" in the viewport and scroll down to "Shading" panel. Then change the shading from the default Multitexture to GLSL. $\endgroup$ – Dr. Who Aug 6 '15 at 15:06
  • $\begingroup$ I've tried using both GLSL and Multitexture, and both Blender Render and Blender Game. All fail to update the texture in the 3d view. I even tried adding a driver to the offset and creating an empty to drive it, but still no luck. The only time changing the offset updates the viewport is when you manually adjust the control. $\endgroup$ – kitfox Aug 6 '15 at 15:15
  • $\begingroup$ Hmmm... This is out of my area of expertise unfortunately. Good luck $\endgroup$ – Dr. Who Aug 6 '15 at 16:10
  • $\begingroup$ use the AnimAll Addon see blender.stackexchange.com/questions/32214/… $\endgroup$ – cegaton Aug 6 '15 at 18:20
  • $\begingroup$ other alternative is animating the coordinates for the texture and leave the UVs alone blender.stackexchange.com/questions/28802/… $\endgroup$ – cegaton Aug 6 '15 at 18:24
1
$\begingroup$

I created a simple .blend file using Blender Render (BI) and put a texture on the default cube and animated the offset X of the texture. I set the viewport to Material (between Texture and Render).

While the Material view shows me the texture, and is updated if I alter the Offset X manually, it utterly fails to draw correctly when that Offset X is altered by the animation system.

I am inclined to say this is a bug in blender, and you are mildly doomed. I say mildly, because when I change the viewport scheme from Material to Render, then I can click around in the timeline and it updates the view correctly. Unforunately, that version of the view is incapable of animating on my laptop (and maybe all computers).

As for the dope sheet, it only shows keyframes for the ACTIVE action. Once you have "encapsulated" the keyframes (probably using the double chevron in the NLA editor) that action is now a strip and you have to select it and Tab into it to make it the active action. It is also important to remember that these keyframes are in the action on your MATERIAL datablock, not your object datablock.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.