5
$\begingroup$

Here I have a model which I am sculpting. In Sculpt mode it is smooth, while in the Object mode it is not. There are no modifiers or anything, so what could be the problem ? Here is the file for a part of the object:

.enter image description here

$\endgroup$
  • $\begingroup$ This may differ if Multires modifier is set to lower level while in Object mode and to higher - when in Sculpt mode (I assume you still have Multires modifier on the object if you are sculpting it) $\endgroup$ – Mr Zak Aug 6 '15 at 8:31
  • $\begingroup$ There is no modifiers $\endgroup$ – Omar Emara Aug 6 '15 at 9:27
  • $\begingroup$ Is there only one object ? There probably could be some overlapping meshes. If it's not the case then I think you should upload a copy of your file (only the problem part of mesh) because it's hard to tell only from screenshots. $\endgroup$ – Mr Zak Aug 6 '15 at 9:48
  • $\begingroup$ @MrZak I added a part of the model $\endgroup$ – Omar Emara Aug 7 '15 at 8:25
  • $\begingroup$ This is a great question and saved me the time of trying to figure out how to word the issue myself. $\endgroup$ – Tyler Feb 25 '17 at 23:06
5
$\begingroup$

Custom split normals data

Your model has a custom split normal data (probably due to a normal edit modifier that has been applied or because the mesh was made with another software...) that keep some face shading in that way.

enter image description here

If you don't need the data, you can clear it to remove the informations, or you can just disable auto smooth to make the split normals data not visible.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ YOU ARE MY HERO. $\endgroup$ – Tyler Feb 25 '17 at 23:03
0
$\begingroup$

Give your mesh an Edge Split Modifier

enter image description here

enter image description here

$\endgroup$
0
$\begingroup$

i tried joining the mesh with a cube and then delete the cube after getting the results. note: you need to select your mesh first and the shift select the cube (or any other object) second when joining it.

$\endgroup$
0
$\begingroup$

Check to make sure Autosmooth is turned off. Had the same problem and turned the auto smooth angle to 180 and both sculpt view and object view finally looked the same.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.