5
$\begingroup$

I'm doing a Blendercookie course on how to sculpt a Scifi weapon with dyntopo. The fact is that when some piece reach a certain level of compleiity (about 1.1 million tris) the systems starts to lags too much and is so frustrating.

I've tried the several options:

  • Disable double sided lighting
  • Enable VBO

I've so also reduced the topology of hidden faces. But that´s how far I've reached.

I'm using a late Imac Intel I5 Nvidia GPU GTX 680mx

any tips out there?

$\endgroup$
  • $\begingroup$ The worst part is Undo... $\endgroup$ – wchargin Oct 25 '13 at 15:10
7
$\begingroup$

Here is an answer by Sanctuary from Dynatopo test thread:

Some performance tips about Dyntopo

  • Do not use Matcap, while it does not show while you're still blocking out your sculpt and you are in early stage of it, Matcap will very noticably impact performance when you're starting to reach mid/high poly . Use that addon instead , gives full control on the Blender existing opengl lights and does not impact performance.

  • Make sure you have Double Sided disabled in the Object Data panel, it's not a nvidia problem only, at higher poly stage the difference in performance with it being enabled or disabled is very noticable on every hardware.

  • Check the Detail level in the Dyntopo setting, too low (like less than 5) that can lead in a -very- lot of triangles generated by your brush strokes , while sometime you may want that, in other time that amount of tris could be really unneeded and can degrade performance. For most of the sculpt time getting detail between 15/20 is good, and for fine detailling, around 10 or a bit less should be enough (remember that when you zoom in you're fine detailling anyways) Less than 10 can be really overkill due the amount of generated tris.

  • You can optimise some part of your sculpt for which you think there are way too many triangles (enable Wire + Display All Edge to see what's going on while you sculpt) by either enabling the Collapse Short Edges button , increasing the detail setting and enabling for your brush the "Simplify" tool (in the bottom header Brush -> Sculpt Tool -> Simplify

  • You can press H and drag a selection to hide those parts while in Sculpt mode, it can help performance really a very lot depending on the kind of polycount you're having of course (ALT+H to unhide)

  • some people have mentionned that the regular freeze/pausing could be related to Blender autosaving (a function enabled by default for each 5 minutes) , you can disable or change the delay for that in File -> User Preferences -> File additionally in freeze/pausing moment, clicking on "Optimise" in the Dyntopo settings may help so it recalculate whatever it has to recalculate

  • If rotating/zooming the view become painfully slow, press Z to switch to wireframe, rotating will then be very fast, press again Z to switch back to solid shading

  • Dyntopo can't currently reach (while keep performance good ) the same kind of polycount you can reach under Multiresolution, fortunately the "detail where needed" system of Dyntopo generating topology only where you work allows for detailled sculpt at a much lower polycount than an equivalent multires would require. So don't be surprised if you can get a workable million in Multires and an unworkable million in Dyntopo. Of course powerfull computers will get higher than less powerfull ones (and if i remember well, Dyntopo isn't multithreaded, while Multires is multithreaded).

$\endgroup$
  • $\begingroup$ Consider revising this answer for 2.79+ as the setting for detail has changed, a higher value is used for detail. $\endgroup$ – Neil Jan 30 '18 at 15:20
4
$\begingroup$

I've found this in the blenderartist forum

  1. Enabling VBOs
  2. Don't have a Subdivision Surface or Multires Modifier at the bottom of your Modifier Stack
  3. Drawing of Outlines is very expensive
  4. non-GLSL Textured modes are slow
  5. (NVIDIA Geforce users only) Disable Double-Sided shading
  6. Non-Power-Of-Two Textures are slow for Texture Painting
  7. Sculpting on lowres meshes can hurt performance
  8. GUI regions can slow down the viewport
  9. Enabling "Show Diffuse Color" can hurt performance

For more detail it's here

$\endgroup$
  • $\begingroup$ Thanks folk! I´ve previosly followed all those steps. It helped, but not enough. $\endgroup$ – Yors de la Jungle Oct 25 '13 at 12:54
  • $\begingroup$ I would add under 'User Preferences'->Editing disabling global undo and setting steps to 0 seem to help. VBO was notorious for adding artefacts (peaks and pits) in random part of the mesh. So if you experience these try to switch VBO off. There was a related bug which is partially fixed (2013-10-25) blenderartists.org/forum/… $\endgroup$ – dimus Oct 25 '13 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.