0
$\begingroup$

Dear StackExchange Community, I am currently trying to import a 3ds file into blender. The Problem is, that all the objects get imported into the origin of the coordinate system and have no extensiveness whatsoever.

The file I am trying to import is a 3D Model of parts of the city of Berlin, which is available for free. http://www.businesslocationcenter.de/berlin3d-downloadportal/

Does anyone have a suggestion as to what could solve my problem?

Cheers Luke

$\endgroup$
1
$\begingroup$

Basically it is a problem with scale and geometry to origin offset and so its easy to fix:

Start with a new blender scene ctrl + N and move the camera, cube and pointlight to another layer. In your scene properties you could set units to metric if you want. In your 3D View go to top ortho view with numpad 7+5 and toggle on the 3D view properties panel with N.

Import the first of your .3ds files and set "Size Constraint" to 1000 (maximum) in the import options (down left). After import just hit home (View > View All) and you should see your objects. Problem is they are very far away from the center and you are not able to view both the center and your objects at the same time with the default viewport clipping values.

In fact your objects are several million blender units away from the center while their origins are at the center. This is a bit impractical to work with ...

To fix this I would do this:

After importing all .3ds files as described above just hit home to bring them all to view. Place the 3d cursor where you want to have your new coordinate center. Select all objects and set their origins to the 3d cursor. Next shift + C to center cursor and shift + S >Selection to Cursor. Finally home again and all should be fine.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.