i am trying to render a one of the mesh primitives, specifically a cube, with an image texture that has texture paint on it.

i succeeded in rendering my cube with the image texture by checking 'face textures' in the found in the 'options' section of the 'materials' tab, but when i added my texture paint over the image Blender rendered a black cube.

why and how could this happen?not the desired render result

desired render result

  • $\begingroup$ the second image is the desired result $\endgroup$ Aug 4, 2015 at 23:49
  • $\begingroup$ Could you upload a .blend sample file? Maybe with the texture packed $\endgroup$
    – Carlo
    Aug 5, 2015 at 0:27
  • 1
    $\begingroup$ What render engine are you using? $\endgroup$
    – PGmath
    Aug 5, 2015 at 1:36
  • $\begingroup$ did you save your texture paint image? (in the UV editor) $\endgroup$
    – gladys
    Aug 5, 2015 at 8:37
  • $\begingroup$ Blender render engine $\endgroup$ Aug 6, 2015 at 0:43

1 Answer 1


To make our life easy blender can remember an image that you choose in the UV/mage editor while uv unwrapping or that you create while texture painting and use it when drawing an object in the 3d viewport. This only happens in the viewport with the right settings but does not carry over into the final render, to use an image texture in the final render you need to setup your material properly.

Recent versions of blender added the ability to add images to paint onto, when using blender internal the texture is normally also created, in cycles when needed a material and/or an image texture node can be created but it doesn't get connected up, you need to do that yourself.

If using blender internal you need to ensure that the texture is added and setup to use the image. For cycles you need to ensure the image texture node is connected to the shader node that you want to use.

  • $\begingroup$ You may want to mention also that (in case of Cycles) one needs either to unwrap the mesh first or connect Texture Coordinates nodes if using another texture mapping mode (as it uses UV mode by default). $\endgroup$
    – Mr Zak
    Aug 5, 2015 at 18:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .