0
$\begingroup$

I am attempting to export my Blender model to Unity but I'm having trouble retaining the view while in texture mode. The issue is that I actually haven't added a texture layer to the model (at least that I can tell), but it still looks much different when I switch modes.

Does anyone have any ideas on why my model would look different in texture mode (as opposed to solid or material mode) and what I could do to retain that appearance when exporting to Unity?

I've attached some screenshots to see the differences below:

Solid mode:

Solid Mode

Material mode:

Material Mode

Texture mode:

Texture mode

$\endgroup$
  • $\begingroup$ I'm not sure what's the problem with your model. If you change material color (diffuse+specular), in the Texture mode you will see those colors displayed, a little bit different than in Material node. If you haven't assigned any material or didn't change its settings, it will display white color, which is what by default. This is as it should be $\endgroup$ – Mr Zak Aug 4 '15 at 17:31
  • $\begingroup$ Ok that makes sense. Is there any way to get that texture appearance to stick in Unity? I'm able to reapply the material but it only makes it look like the material mode screenshot as opposed to the texture mode screenshot. $\endgroup$ – Kyle Bachan Aug 4 '15 at 20:57
  • $\begingroup$ Could you please upload the example of your .blend file on something like pasteall.org ? I'd say you could add a texture to your model and simply fill it with that color you'd like. Still I'm not sure which options have you changed in material so it may not work $\endgroup$ – Mr Zak Aug 4 '15 at 21:32
  • $\begingroup$ Ok here's the link to the .blend file. Thanks for your help: pasteall.org/blend/37440 $\endgroup$ – Kyle Bachan Aug 5 '15 at 1:57
  • $\begingroup$ Did I understand you right that you'd like to make parts of model with material "red full.001" while rendered look exactly as do those bright red arms in Texture mode ? $\endgroup$ – Mr Zak Aug 5 '15 at 11:51
3
$\begingroup$

To make your model while rendered have that bright red color you see in Texture shading 3D view mode you can setup it in 2 ways:

  1. Make the material shadeless:

    enter image description here

    The result:

    enter image description here

    However, it's not good approach as it's much less flexible; you will loose possibility of the material to have shadows and thus it may not suit your needs.

  2. You can setup a texture for your material.

    With that material selected ("red full.001" in your case) go to Texture tab and create new one. Select it's type Blend and check Ramp option in Colors scroll. Delete one of the color stops, select another and copy the color from your material setup to this color stop (it may be easier to use Hex triplet for that):

    enter image description here
    Note: the texture should be checked to influence on the material (near its name in the list); I forgot to check it back when I made screenshots

    The resulting material is bright, at the same time receiving shadows:

    enter image description here

    I also checked Color checkbox in Specular options in the Influence scroll (so the texture to influence on the specularity, instead of material; to return material specularity color uncheck that).

$\endgroup$
  • $\begingroup$ Thanks so much, this seems to be just what I'm looking for. So far it seems to be working--I'm going to attempt to export my file into Unity and see if the texture is retained. $\endgroup$ – Kyle Bachan Aug 5 '15 at 17:23
0
$\begingroup$

Solid mode displays only the viewport color you have set in the materials tab unlike the material mode and texture mode, material mode is showing the light highlights unlike Solid mode and Texture mode. When you will import your model to unity you will not see any textures as you have to manually apply them to your materials, just drag you textures to the albedo of the material or just drag the texture on to the object.

$\endgroup$
  • $\begingroup$ The main issue I have is that I don't seem to have applied any textures at all to my model (only materials) and yet it looks completely different while in texture mode. Do you know why this might be the case? $\endgroup$ – Kyle Bachan Aug 4 '15 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.