0
$\begingroup$

I have the following blend file.

I am trying to use constraints to make the camera follow the cube(named "logic bricks player"). I tried copy location with offset to keep the camera at its height, but it did not work. Also just parenting the camera does not work cause it loses the rotation. Even when I tried to bypass it by pressing "Keep transform" the camera disappeared!?! (I know this cause I used plane to track it).

The thing is though, that the constraints worked in the 3d viewport but failed to work during gameplay.

I have no idea what I am doing wrong and I am new to the use of constraints in bge. So how do I fix my problem?

(credits for the hand rig go to eGlyde from blendswap,it was his model)

$\endgroup$
  • $\begingroup$ blender.stackexchange.com/questions/16624/… @Lev, constraints are not supported for BGE, try using a logic brick equivalent, (the camera actuator comes to mind) $\endgroup$ – Scalia Aug 4 '15 at 15:35
  • $\begingroup$ Oh damn, ok make it into an answer to mark it, or mark it as a duplicate if you can. $\endgroup$ – Lev Aug 4 '15 at 15:38