5
$\begingroup$

Before, checking the "Lock to Cursor" option in the "View" tab, permanently locked my 3D-view to the cursor, meaning wherever I clicked, the view would automatically center to and rotate around. Since I updated to 2.75 though, this doesn't work anymore. Now, when I check "Lock to Cursor", all it does is use the cursor as a pivot point. The 3D-view rotates around the cursor, but it the view doesn't center to the cursor.

This makes editing pretty frustrating, since i always used to navigate the 3D-view like that. every effort to find some option in the user preferences was unsuccessful.

$\endgroup$
1
  • $\begingroup$ Same issue here. I found the former "lock to cursor" behaviour much more intuitive and I'm having a hard time getting used to it. Although I can understand that this is a personal preference. Therefore, it might be better better to be able to select between both options. $\endgroup$
    – user21350
    Jan 29, 2016 at 18:52

1 Answer 1

5
$\begingroup$

This was changed in this commit:

The view would jump each time, now compensate by adjusting the cursor panning. Less jarring and helps avoid problems when the cursor gets outside the view, see: T40353

You can now center the view on the cursor with 3D View Header > View > Align View > Center View to Cursor, or, while Lock to Cursor is enabled, 3D View Header > View > Frame All (Home).

screenshot showing the view > frame all, view > align view > center view to cursor, and 3D view sidebar > view > view lock > lock to 3D cursor settings, each highlighted with an orange box

In the Blender 2.7x keymap, Center View to Cursor is bound to ⎇ AltHome.


There are several bug reports from users who appear to have missed this functionality, so perhaps if you send a message to the bf-funboard with an explanation why and how the old behavior was more useful than the new behavior, the developers may decide to add it back in some form.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .