9
$\begingroup$

I am starting to learn using blender, and at some point I managed to do something to the 3D view camera.

Usually the camera orbits around an object, but now the rotation seems to happen (atleast very close to) around the "camera's origin". Neither the input setting in "User Preferences", the pivot point selection nor Ctrl-Alt-Shift-C (as suggested on some forum) do anything to the issue.

$\endgroup$
  • $\begingroup$ Try Shift+C and Numpad . (period) $\endgroup$ – gandalf3 Oct 24 '13 at 23:29
  • $\begingroup$ Related: blender.stackexchange.com/q/696/599 $\endgroup$ – gandalf3 Oct 24 '13 at 23:31
  • $\begingroup$ @gandalf3 Both move the camera, but neither of those fixes the pivot. I think the issue is not the "pivot", but that the camera is in a wrong mode of some sorts $\endgroup$ – varesa Oct 24 '13 at 23:35
  • 2
    $\begingroup$ By "camera", do you mean the viewport view or the scene camera object? $\endgroup$ – gandalf3 Oct 24 '13 at 23:37
9
$\begingroup$

It sounds like you centered the view on the camera.
Here are some ways to set the view center:

  • ShiftB or 3D view header > View > Zoom Border (Note that this will also zoom to fit the view to the defined border)

  • Select an object/vert/face/spline etc. and press Numpad . (period) to center the view to the selection.

  • Press ShiftC to center the view to the world origin (default). Note this will also center the 3D cursor.

If none of these work, then it sounds like you have Locked the view pivot to the camera object (ShiftNumpad .). See if there is any object selected in the Lock to object option in 3D view > Properties region (N) > View > Lock to object:

enter image description here

You can remove this lock by clicking the X next to the object name, or pressing AltNumpad ..


CtrlShiftAltC is a shortcut for snapping object origins. (it does not affect the view)

$\endgroup$
  • $\begingroup$ "View -> Lock to object" did the trick. I had somehow specified a (scene) camera there. $\endgroup$ – varesa Oct 25 '13 at 8:54
3
$\begingroup$

Helpful tip here, even though it's already been answered: You can also press Shift + Num . to lock it, and Alt + Num . to unlock.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.