2
$\begingroup$

i'm trying to render my scene from a script. i've got some objects with materials that are Shadeless, and when rendering with the blender renderer in my script, they show up as expected: no shading. if i use the opengl renderer from my script, they do not. even if i delete the light, the objects show up with shading.

i tried using bgl.glShadeModel() in my script to no success, though that didn't make much sense to me anyway.

is there a way to specify that the opengl renderer should render the same way as the blender render, using the material's Shadeless property correctly? note that the material is pretty simple: a color, and that is being picked up properly.

$\endgroup$
  • $\begingroup$ Do you have GLSL enabled? $\endgroup$ – TARDIS Maker Aug 3 '15 at 18:58
  • $\begingroup$ For a better understanding, please add an image of the desired shader (blender renderer). For the rendering procedure see this answer: blender.stackexchange.com/a/27640/3710 $\endgroup$ – p2or Aug 3 '15 at 20:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.