3
$\begingroup$

I'm rendering volumetric clouds using Procedural cycles Clouds shader. I'm getting a good result, but with a strange noise (middle bottom screen):

enter image description here

It's about 180 passes. As you can see everything is good, but this place is noisy.

How to reduce it next time?

Also first time I used a default Transparency value – Min 3, Max 8. I got this result: enter image description here

As you can see in the same place a black box are visible. In other places you can see other boxes. I think it is one of many particles border. I reduce it by increase Transparency value.

Why the boxes are visible with default Transparency value?

May be I should change another value to achieve better result?

Thanks for your suggestions!

$\endgroup$
  • $\begingroup$ Regarding your first question you may try to lower down to 0 Volume value in the Light Paths scroll $\endgroup$ – Mr Zak Aug 2 '15 at 8:16
  • $\begingroup$ Tnx, Mr Zak, I thought higher value = more passes = higher quality. It is not right? $\endgroup$ – Ilya Kanatov Aug 2 '15 at 9:29
  • 2
    $\begingroup$ It is, but it's rather widespread technique to set Volume as I said to 0 so to keep render times under control. You have to set really high amount of samples to render with even 1 bounce and clean out noise (probably also with using some other tricks). $\endgroup$ – Mr Zak Aug 2 '15 at 10:02
2
$\begingroup$

I had the same issues when I used the same shader recently (in Blender 2.79). This is how I solved them:

I. Decrease the Step Size value.

I realized that I had to reduce the Volume Sampling Step Size (Under Geometry section in the render settings). This removed noise in those areas where the volume density is very less.

But there are side effects of doing this:

  1. This will increase render times, so you will have to find the exact value which is good enough to remove the noise.
  2. The clouds would look more denser, so you may have to decrease the overall volume density in the shader.
  3. Some cloud volume, if placed far away, might disappear, or get cut if Max Steps value is set low. You may have to increase the Max Steps value if that happens.

Tip: Step Size and Max Steps properties work in relation to each other. Reducing Step Size may need increase in Max Steps in order to make distant volumes visible since the renderer may reach the maximum number of volume sampling steps before it reaches the far away volume (because it is taking a smaller step to calculate the volumetric shader)

II. Regarding the black boxes, Increase the Max value for Transparency under Light Paths. Increasing the value did not affect my render time.

All the cloud instances are rendered inside cube geometry with a transparent shader on it by default (if no surface shader is defined and volume shader is connected). Now since the volume and background ray has to travel through many of these transparent boxes to reach the camera (or from the camera), sometimes it may hit the maximum transparency bounces value and that will render a black box there as the volume ray and the background image cannot pass through.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.