0
$\begingroup$

When I try to play my game, the scene gets messed up. I think it is better if I show you what I mean.

Image: Incorrect rendering (second image)

The skydome is completely gone and the order in which the models render is completely wrong. I tried a lot of things, but nothing seems to fix it.

EDIT: The problem with the skydome is fixed. I had to flip the normals.

EDIT #2: Here is a link to the .blend file: http://www.mediafire.com/download/lm3i4n78gcok8q2/Station_of_Awakening.blend

$\endgroup$
  • 2
    $\begingroup$ probably camera clipping issue, check this : blender.stackexchange.com/a/18291/11431 $\endgroup$ – Bithur Aug 1 '15 at 14:10
  • $\begingroup$ Thanks, but that didn't fix it. The problem is not the render distance, but the skydome doesn't render at all. $\endgroup$ – RaichuBender Aug 1 '15 at 14:15
  • 1
    $\begingroup$ try to recalculate or flip the normals, else you'd better upload the blend file $\endgroup$ – Bithur Aug 1 '15 at 14:16
  • $\begingroup$ Yes, thanks, the skydome problem is fixed, but the rest is still messed up. $\endgroup$ – RaichuBender Aug 1 '15 at 14:18
  • $\begingroup$ post a .blend file $\endgroup$ – Bithur Aug 1 '15 at 14:21
2
$\begingroup$

Oh, haha, I guess I figured it out myself. Sorry.

I fixed the problem by selecting GLSL instead of Multitexture in the Properties > Render > Shading menu. Let me show you: Fixed

$\endgroup$
  • $\begingroup$ glad you found, i was replacing the materials with a simple one with a grid texture and it would take forever :) (can't see anything but pink!) $\endgroup$ – Bithur Aug 1 '15 at 14:42
  • $\begingroup$ Thanks for your help, anyway. Thanks to you I fixed the skydome, even though it has some cutoff :P $\endgroup$ – RaichuBender Aug 1 '15 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.