1
$\begingroup$

I think we have all been there: we add too many objects or subdivide something too many times and suddenly Blender slows down to a crawl. At the moment my system is so unresponsive that it takes minutes to cancel what I did to slow it down. This problem leads me to ask if there is a way to temporarily disable Blender from trying to update things in the UI/Viewport, so that I can tweak the settings and make it responsive again?

$\endgroup$
6
  • $\begingroup$ did you use a lot of modifiers? $\endgroup$
    – gladys
    Aug 1 '15 at 8:18
  • $\begingroup$ Sometimes yes, it depends on the project. $\endgroup$
    – Antti
    Aug 1 '15 at 10:01
  • $\begingroup$ if you used a lot in this project I would disable the display modifier in viewport. (the eye-icon in the modifiers) $\endgroup$
    – gladys
    Aug 1 '15 at 10:09
  • $\begingroup$ I'm not using modifiers currently, I am using the animation nodes addon though. But I'm wondering if there is something to stop UI updates in general. Like in After Effects where you can hit caps lock to temporarily stop drawing the composition. $\endgroup$
    – Antti
    Aug 1 '15 at 10:12
  • $\begingroup$ Animation Nodes performance tab doesn't help? $\endgroup$
    – p2or
    Aug 1 '15 at 12:38
1
$\begingroup$

In recent versions, viewport updates are not computed for Objects that:

  1. Are disabled in Viewports in the Outliner.
  2. Are also not required by any Viewport-enabled Objects in the depsgraph.

So to quickly make changes without waiting for viewport updates on every input, you may disable the heaviest objects in the Outliner, then select them in the Outliner.

enter image description here

At the time this question was asked, I believe the same behaviour could be reached by switching to an empty Layer.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.