I've been learning how to use UV mapping with textures in Blender. Things have worked fine so far using simple shapes like cubes and cylinders, but everything went wrong when I tried to UV map a creature mesh. It looks how I'd expect in 3D View: brown with a lighter color on its belly. However, the render is all messed up.

Comparison with 3D view on left and render on right: enter image description here

The creature's properties: enter image description here

  • $\begingroup$ Kallenboone, welcome to the site. If you would upload your ~.blend file to Blend-exchange or a similar site so that those who would wish to help you could see your actual file, that would be more useful than the edited screen shot you provided. $\endgroup$ – brasshat Aug 1 '15 at 4:51
  • $\begingroup$ Do you have a subdivision modifier on the model? $\endgroup$ – Denis Aug 1 '15 at 4:54
  • $\begingroup$ @brasshat Thanks for the tip! I couldn't find a way to upload my files here, but I put them up in my public Dropbox folder. Blend file: dl.dropboxusercontent.com/u/28277866/creature.blend Texture: dl.dropboxusercontent.com/u/28277866/creature.png $\endgroup$ – kallenboone Aug 1 '15 at 7:08
  • $\begingroup$ @Denis I do indeed. The texture is still messed up if I turn off the subdivision modifier, though. $\endgroup$ – kallenboone Aug 1 '15 at 7:10

Nothing is wrong with your UV set up. It looked fine when i opened it. I didn't change anything in your blendfile, except for the lighting. I put 2 sun lamps in the scene near the camera and pointed it at the object. And deleted the 3 lamps you added.

enter image description here

  • 2
    $\begingroup$ @kallenboone the problem is in the light because you applied the creature's texture on 2 of them $\endgroup$ – Bithur Aug 1 '15 at 11:32
  • $\begingroup$ That fixed it. Thanks for the help! I didn't even know it was possible to have a texture on a lamp like that. The next part of the guide I'm following is all about lighting, though, so that should be enlightening. $\endgroup$ – kallenboone Aug 1 '15 at 16:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.