1
$\begingroup$

To open multiple instances of Blender on a Mac, I'm opening blender.app (2.75a and 2.75) through the console. That makes Blender's interface load with most of the text gone: loadBug

Vs. the normal way of opening Blender with Finder: Normal startup

I tried:

open -n .../blender.app
open -n .../blender.app/contents/MacOS/blender

I also tried only ./ and tried to open the app manually inside the package contents, all with the same result. I also tried with 2.74, and the same happens. Oddly enough I am looking at a tutorial in which the guy has 2 instances opened on a Mac without much problem.

So, what's going on? If I have to make 2 instances of blender.app, it's ok, but how can I get the console window method to work?

$\endgroup$
1
$\begingroup$

I had two versions of python installed; I solved this by uninstalling the 2.7 version by typing:

sudo rm -rf /Library/Frameworks/Python.framework/Versions/2.7

and then:

sudo rm -rf "/Applications/Python 2.7"

That leaves me with 3.4, and everything works fine.

$\endgroup$
0
$\begingroup$

I just downloaded Blender 2.75a on my mac with OSX 10.10.3 (Yosemite). Placed on my desktop, I open the terminal and executed this line:

/Users/[myusername]/Desktop/Blender/blender.app/Contents/MacOS/blender

Blender loaded properly with all menus intact. No "open" command is required. I can do multiple instances this way.

$\endgroup$
  • $\begingroup$ Ill try that way, wait a sec $\endgroup$ – Kaahrl Jul 31 '15 at 15:31
  • $\begingroup$ after typing : /Users/(-U-N-)/Desktop/blender.app/Contents/MacOS/blender; blender opens, but still I will get the very same issue that the screenshot shows, also I noticed this message in the console: .../Desktop/blender.app/Contents/MacOS/blender ndof: 3Dx driver not found Read new prefs: /Users/Kaahrl/Library/Application Support/Blender/2.75/config/userpref.blend 2015-07-31 17:35:10.164 blender[31188:7772658] 17:35:10.164 WARNING: blablabla $\endgroup$ – Kaahrl Jul 31 '15 at 15:39
  • $\begingroup$ as a matter of fact I 99% sure that is something about my mac configuration since I saw this work to everybody.... $\endgroup$ – Kaahrl Jul 31 '15 at 15:41
  • $\begingroup$ and yeah Yosemite here too... maybe something about permissions/ priviledges etc...? is like if it couldn't read part of the program $\endgroup$ – Kaahrl Jul 31 '15 at 15:42
  • $\begingroup$ oh, I think myght be something about my python config since at the end of the console you can read: uiItemStringO: 'WM_OT_url_open' unknown operator python line lookup failed, interpreter inactive search for unknown menutype USERPREF_MT_splash_footer $\endgroup$ – Kaahrl Jul 31 '15 at 15:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.