4
$\begingroup$

When I switch to render mode, they show up, and they show when pressing F12, but when clicking the 'Animation' button, nothing shows. If anyone knows how to help, please do.

Edit: I have enabled rendering using the cameras, still nothing.

Edit #2: What the, some how transferring all of the objects from layer 1-2 does the trick. I guess my camera was set up for the second layer even though it was physically in the 1st. Anyone like to explain?

For anyone who's really curious, Here's the file:

Also, it may seem like having the animation length of 1 frame seem bad, but I've done that for other files and they work fine.

$\endgroup$
  • $\begingroup$ Did u mean objects not showing up in final render? $\endgroup$ – Kesha Wilson Jul 30 '15 at 15:30
  • 1
    $\begingroup$ There are many possible reasons, please add a meaningful screenshot or the blend file to the question. Also see: blender.stackexchange.com/questions/33787/…, blender.stackexchange.com/questions/18884/… $\endgroup$ – p2or Jul 30 '15 at 15:31
  • 1
    $\begingroup$ Okay make sure then the object you are trying to render has render enabled. In the upper right hand part of the screen with all the objects, there should be a camera looking button next to the eye (hide or show). Did you try enabling that? $\endgroup$ – Kesha Wilson Jul 30 '15 at 15:33
  • $\begingroup$ can you upload your file? $\endgroup$ – cegaton Jul 30 '15 at 16:35
  • 1
    $\begingroup$ I confirm the problem comes from render layers : all objects on 1st layer, render only 2nd. I just don't understand why F12 render shows something else. I think Mr Zak should answer this :) $\endgroup$ – Bithur Aug 1 '15 at 23:46
7
$\begingroup$

There are two possible reasons for this happening.

Reason I - Object Render Disable


You can disable specific objects from being rendered in the Outliner. It is possible you did this without knowing it.

Outliner Panel

The Camera Button to the right of the Cube Object is disabled, meaning the Cube will not be rendered. Click the camera button to turn on/off rendering.

Reason II - Render Layer Settings


It could be that you have disabled the Render Layer(s) of your object in the render layers.

render layer panel

In the example photo, Scene: layer 1 is active and will preview render in viewport, but since Render: layer 1 is not active, then The objects in Layer 1 will not actually render.

More Render Layer Explanation - The square buttons below 'Scene:' are the layers that are active and currently shown in 3D viewport. You have these correctly selected if you can see them in the 3D viewport and see them in the render preview.

The buttons below 'Layer:' are the layers that will be rendered. Select every layer that you have objects on to render.

The buttons below 'Mask:' will cause what ever objects on this layer to cut a transparent area through your render.

$\endgroup$
1
$\begingroup$

I deleted the camera and added a new one, everything became visible again.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.