When I hit F12 to render an image and zoom in it is quickly pixelated.
How can I render a higher res display? I have looked through the settings and couldn't find a solution.

  • $\begingroup$ Check too that you didn't accidentally zoom in the render with your mouse scroll button. $\endgroup$ Nov 2, 2015 at 16:48

1 Answer 1


You can set the output resolution of the render in the Properties Editor > Render settings > Dimensions Panel:

enter image description here

For a description of each of these settings, see the Manual:

The Dimensions section has settings for the size of the rendered images. By default the dimensions SizeX and SizeY are 1920×1080 and can be changed by adjusting the X and Y fields. These buttons control the overall size of the image.

Slider to reduce or increase the size of the rendered image relative to the X/Y values above. This is useful for small test renders that have the same proportions as the final image.

Note you can quickly increase or decrease the resolution while keeping the same aspect ratio by setting the Percentage slider below the resolution settings:

enter image description here

Note that to set the Precentage a value greater than 100% you will have to type the value in directly.

For Blender 2.8+ the render size is now in the Properties Window > Output Properties tab

enter image description here

Other methods

Note that it is possible to type a quick python math expression such as 1920*2 directly into the value box: (helpful for quick arithmetic to precisely set values. This works for all value boxes, not just resolution settings)

enter image description here


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .