1
$\begingroup$

I am making a house in Blender in wich i want to walk around using Blender game engine. Everything displays well, but when i press "P" to start the game, it renders only a few poligons from the entire scene. What can be wrong? Thank you so much!

Print 1 enter image description here

$\endgroup$
  • 1
    $\begingroup$ Did you try to recalculate normals? $\endgroup$ – Denis Jul 28 '15 at 13:33
  • $\begingroup$ I did just now, still doesn't work. $\endgroup$ – Andrei Jul 28 '15 at 13:34
  • $\begingroup$ @Andrei , you may need to manually flip normal or give the trouble walls thickness, alternatively, you can un-check the backface culling option under game-options in the materials tab. It also looks like you are using MultiTexture to render your scene, GLSL gives better results. $\endgroup$ – Scalia Jul 28 '15 at 14:58
  • $\begingroup$ I unchecked Backface culling, i set the shading to GSLS, i applied Solidify modifier, the same. I don't know how to manually flip normals... $\endgroup$ – Andrei Jul 28 '15 at 15:31
3
$\begingroup$

Some faces won't render so what it means is that you propably have Backface culling activated(means that only the faces in the direction of the normals are getting rendered).

Select the object whose faces won't appear.

Then go into edit mode by pressing tab.

In the "N" panel find the mesh display and under "Normals" select faces (the 3rd icon).

Blue lines (these segments are called Normals) are gonna come out of the faces of your object. The faces will be rendered from the side these blue lines go to. So if the faces that won't render have their blue lines going inside, it means this is your problem.

What you should do to fix this is:

press ctrl+N (with the faces still selected) and then in the "T" panel the "Make normals consistent" option is gonna appear with an unchecked box. Check it and it should be fine. This is the manual way in case of selecting all faces and pressing ctrl+N won't fix your problem.

p.s. if you want your plane to render both ways, deactivate backface culling in the "N" panel below shading mode.

$\endgroup$
  • $\begingroup$ I apreciate your consistent answer and i did everything you've said, but unfortunately this couldn't solve my problem, only partially. I atached prints: postimg.org/image/83gj0xq6p and postimg.org/image/extrqmfa5 $\endgroup$ – Andrei Jul 29 '15 at 8:53
  • $\begingroup$ Can you share the blend file through pasteall.org/blend , so I can have a look at it? $\endgroup$ – Lev Jul 29 '15 at 12:14
  • $\begingroup$ Oh my god, i figured it out, "Backface culling" was enabled in many other materials, i though it was something general wich is enough to disable it once. Than you so much for your advices! $\endgroup$ – Andrei Jul 30 '15 at 13:55
  • $\begingroup$ Nice job lev, couldn't have said it better myself... oh.. one sec. :D $\endgroup$ – Scalia Aug 3 '15 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.