1
$\begingroup$

I am trying to follow the Kenan Proffitt tutorial on YouTube for two point motion tracking but the Foreground and Background layers are not appearing in the compositor.

When I add the video input node and select the video I get a small square in the node with the video.

When I add the two Render Layer nodes (for my two layers) and select my scene I don't get that small preview square - and there is nothing from these layers in my final render. I also get nothing if I plug the Render Layer node(s) directly into the viewer or composite node.

Picture of nodes without little window:

enter image description here

Blend file

$\endgroup$
3
  • $\begingroup$ have you rendered your scene? $\endgroup$
    – gladys
    Jul 27, 2015 at 20:31
  • $\begingroup$ I think so - I hit F12 and have the Rendered view in the bottom right. That does not have the layers on it. I also hit the "Animate" button but that did not have any of the information from render layers in the final video either (it was simply a newly rendered version of my original video). $\endgroup$ Jul 27, 2015 at 20:34
  • 1
    $\begingroup$ Delete the movie from the video editor and then hit F12. Then the render will be visible. $\endgroup$
    – gladys
    Jul 27, 2015 at 20:59

3 Answers 3

3
$\begingroup$

Delete the movie from the video editor and then hit F12. Then the render will be visible.

$\endgroup$
3
  • $\begingroup$ Thank you so much for taking the time to answer. I would never have found this on my own. Now working perfectly. $\endgroup$ Jul 27, 2015 at 21:28
  • $\begingroup$ @BlenderJames Welcome to the site :) If this answer has satisfactorily answered your question, then consider marking it as accepted. $\endgroup$
    – gandalf3
    Jul 28, 2015 at 0:02
  • 1
    $\begingroup$ unchecking "sequencer" in render tab can do the trick too $\endgroup$
    – Bithur
    Aug 1, 2015 at 13:52
0
$\begingroup$

Go to compositor screen, press ⇧ Shift + A and type rendering layer in search

$\endgroup$
0
$\begingroup$

For me it was the Use Nodes checkbox not being checked. It's at the top left of the screen.

Blender top menu screenshot

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.