3
$\begingroup$

I just finished an animation of the Hulk. When I try to render the animation, the top of the head and the hair don't show up even though they do in my workspace. I asked another question regarding how the hair mesh on hulk doesn't move properly with my armature, and I have a feeling this has something to do with it. I temporarily fixed that issue by creating a skull and turning on "Bone Envelopes".

Here are some pictures illustrating my issue:

Workspace:

Hulk in animation window

Rendered png: Hulk in render

Blend File

$\endgroup$
0
3
$\begingroup$

The first issue is that you have set the hair material to be a 'Mask' material. You can disable this by going to the 'Transparency' panel in the material options for the hair material and un-ticking the box next to 'Transparency':

enter image description here

If you want to use transparency for the hair you can set it to 'Z Transparency' or 'Raytrace'.

To get the hair to render as transparent you need to tell the material to use the transparency of the image you are using. On the hair material go to the texture panel and under the 'Influence' panel make sure 'Alpha' is turned on.

enter image description here

You can then turn the 'Alpha' value in the first screenshot to '0' as you are giving full control of the alpha over to the image.

Finally, because you are now using transparent textures, which will cast transparent shadows, you need to set both materials to 'Receive Transparent' in the 'Shadow' panel of the material options:

enter image description here

$\endgroup$
4
  • $\begingroup$ Hey! Thanks for the help. That seems to have solved my problem while in the workspace. But, when I try rendering, the hair appears as a grey helmet over Hulk's head: imgur.com/4oC3CLM I think this has something to do with how the hair doesn't move properly with the armature. Hulk gets a big visor of hair when I turn off the transparency: imgur.com/o9dBqPe. (Even with transparency on, he has dreadlocks in front of his face). $\endgroup$ – Jerry Hsu Jul 28 '15 at 13:45
  • $\begingroup$ That is because the hair isn't in a vertex group, so isn't being controlled by any bones, it's staying in place while everything else moves. But this is a separate issue to your question so I would suggest asking a new question if this comment doesn't help. $\endgroup$ – Ray Mairlot Jul 28 '15 at 14:09
  • $\begingroup$ I've added the hair vertices to groups controlled by bones and it works likes a charm! But, back to the original problem, the rendered Hulk still has a grey helmet over his head: imgur.com/i4uvR8y. He looks a little better in the workspace with a full head of hair: imgur.com/4fTEGfH, but I really want him to render out as he looks with transparency turned on for the hair: imgur.com/8AbWVxj $\endgroup$ – Jerry Hsu Jul 28 '15 at 14:50
  • $\begingroup$ I have updated my answer. $\endgroup$ – Ray Mairlot Jul 28 '15 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.