3
$\begingroup$

I have a simple texture, of a bush (for a billboard plane) There are very annoying white artifacts around the edge of the plane.

I am using GLSL shading in the BGE.

Picture of the problem would normally be here. Problem is in the 3D view Contrasted to no problem in the image editor

             UV/Image Editor                             3D View

There is no white edge on the actual texture, however, one appears on the plane.

Texture Settings are Below, Material Settings are below and to the right

Picture of the texture settings would normally be herePicture of the material settings would normally be here

Blend file

Textures

Get the ones that start with Bush1_ and Plants_

$\endgroup$
  • $\begingroup$ Related: blender.stackexchange.com/q/1625/599 $\endgroup$ – gandalf3 Jul 27 '15 at 19:06
  • $\begingroup$ Hence why I said "related" ;) Does the artifact appear in the game? Or only in the viewport? $\endgroup$ – gandalf3 Jul 27 '15 at 19:09
  • $\begingroup$ Have you played with the pre-mult alpha option in the texture panel? THis usually alleviates the problem. It would also help if you can share the texture so we can be sure texture is not the issue. $\endgroup$ – Mike Pan Jul 27 '15 at 19:56
1
$\begingroup$

In the material Game Settings section change Alpha Blend from Opaque to Alpha Clip, and in Transparency section you can adjust the Clipping amount by increasing or decreasing the Alpha value.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ This totally fixed my problem. (the leaves look a bit smaller now, but it is so much better!) I'd kinda like to know what is causing this in the first place so I can prevent it for the future. $\endgroup$ – X-27 wants to Reinstate Monica Jul 27 '15 at 23:53
  • $\begingroup$ @X-27 I assume that the artifacts on the edges caused by the image compression. $\endgroup$ – Denis Jul 28 '15 at 0:00
  • $\begingroup$ the image is a .png There shouldn't be any weird compression. $\endgroup$ – X-27 wants to Reinstate Monica Jul 28 '15 at 0:37
  • 1
    $\begingroup$ @X-27 I just saw that the alpha channel has a white color, usually what happens is that people use another image as an alpha mask that has the shape of the background, and if the color is not the same as the color of unmasked pixels, the blend between the alpha and the rest of the image will create the visible artifacts where the border is. $\endgroup$ – Denis Jul 28 '15 at 1:30
  • $\begingroup$ That kinda makes sense, but I hand drew this texture in Photoshop, and I wasn't using a mask, could it just be the way that Photoshop handles the alpha channel? $\endgroup$ – X-27 wants to Reinstate Monica Jul 28 '15 at 17:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.