1
$\begingroup$

I am talking about Cycles. Why does it produce shading artifacts on low poly models in smooth shading especially close to the edges? I usually fix them by adding more vertices, edge splitting etc but why is this required and is it the only way? I've noticed that in game engines or some other 3D apps the shading on the same models looks fine.

Here's a small example in Cycles enter image description here

Here's the exact same mesh in another render engine enter image description here

$\endgroup$
  • 2
    $\begingroup$ because of normals ( there are similar questions here ) $\endgroup$ – Chebhou Jul 25 '15 at 16:08
  • $\begingroup$ The normals of the models are pointing the right way if thats what you mean. $\endgroup$ – user40079 Jul 25 '15 at 16:51
  • $\begingroup$ can you upload an image? $\endgroup$ – user1853 Jul 25 '15 at 17:56
  • $\begingroup$ Sure, I just did. $\endgroup$ – user40079 Jul 25 '15 at 19:15
  • 1
    $\begingroup$ @user40079 If you're looking for a low poly style, then perhaps you might want to turn off smooth shading. If you just want to keep the poly count down, then I'd suggest that cycles is the kind of render engine where it's perfectly excepted to feed it mid to high poly meshes even for small or relatively simple objects. Trying to render super low poly meshes realistically (like you would in real-time renderers) may not work so well $\endgroup$ – gandalf3 Jul 25 '15 at 23:07