0
$\begingroup$

I have a problem with combining hooks modifier with Armature. I tried to place armature at different places on modifier stack, but nothing works as I wanted.

Here's Armature in Rest Position without hooks. Here's Armature in Rest Position without hooks

Here's Armature in Rest Position with hooks (Hooks are parrented to eachother, and the hooks that are chain roots are parented to a hand bone). Here's Armature in Rest Position with hooks

After swiching Rest Position into Pose Position, empties follow the hand bone, which is great, but the mesh is... messed up. Here's Armature in Pose Position with hooks Here's Armature in Pose Position with hooks How I can repair this?

And yes, I really need to use hooks for animating hand ; )!

$\endgroup$
2
  • 1
    $\begingroup$ Both the hooks and armature are deforming the mesh? I expect that would be the problem, the armature moves the mesh 2cm and as the hooks also move 2cm the two movements are combined making the mesh move 4cm. Try removing the weight painting from the fingers so that only the hooks move the mesh. $\endgroup$
    – sambler
    Jul 26 '15 at 14:52
  • $\begingroup$ As far as I can check your solution - it's not completly working, but it is a little better. Anyway I was forced to used armatures , maybe when I will have some free time I will recreate my set (armature+hooks) and then try every possibility. $\endgroup$
    – evilferber
    Jul 27 '15 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.