11
$\begingroup$

I am trying to select the cube that in the middle of the scene. How can I select it? All I see is a crosshair appearing everywhere I click. Is this a bug?

$\endgroup$
14
$\begingroup$

That circle/crosshair is the 3D cursor.

To select you need to Right click instead of Left click.
You can change this behavior in File > User Preferences (CtrlAltU) > Input:

  1. Open the User Preferences:

    *File > User prefs*

  2. Go to the Input tab. The select left/right options are under Mouse:

    Set preferences

  3. If you want to save these settings as the default for the next time you open blender, click Save User Settings in the Header (at the bottom of the window):

    Save user settings

This is one of the most controversial parts of blenders UI.

For some further information you might want to check out:

$\endgroup$
  • 3
    $\begingroup$ Well that is annoying. Why blender why! every other program is left click. :) $\endgroup$ – BlenderBoy Oct 21 '13 at 19:43
  • 1
    $\begingroup$ @BlenderBoy This is been a topic of a lot of controversy lately.. $\endgroup$ – gandalf3 Oct 21 '13 at 19:46
  • 1
    $\begingroup$ Agreed. but you get used to it... UNTIL you move to another app (such as image editing) and get infuriated because you're right clicking things and it's not working. $\endgroup$ – MrVimes Oct 21 '13 at 19:49
  • 9
    $\begingroup$ Strange. I have no problems with that whatsoever. And one big word of advice: Blender is not meant to by tried out. It's a highly complex very powerful tool that needs at least some tutorials to learn. $\endgroup$ – Haunt_House Oct 22 '13 at 2:33
  • 7
    $\begingroup$ Lets not turn a troll question into yet another UI discussion. $\endgroup$ – Greg Zaal Oct 22 '13 at 7:24
1
$\begingroup$

You can change this in the User Preferences pane found at the top left of the main window in the File menu.
Next click the Input tab, then locate Select With, you will see two options which are Left and Right.

You may also want to look a little further down for Invert Zoom Direction if the current mouse wheel zoom seems backwards to you.

At the very bottom, you should see a button that says Save User Settings, click this to save the change. Just be sure to remember this when you are following any tutorials or you will end up really confused. It's really not a big deal once you know what's going on here.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.