0
$\begingroup$

I have some Blender model assets associated with a Unity book I am working through (Unity Android Game Development by Example Beginner's Guide from Packt). The book came out in 2013 and the assets were presumably made with an older version of Blender (I have the latest, 2.75a). Every face in the model seems to have gone missing. All of the vertices are there and the models appear as wireframes that are recognizable, but there is nothing that is renderable and you can't export the models to an FBX as the result is an empty file.

I'm trying to save the TankBattleCity model and I discovered that if I create a face out of four vertices, such as on the obelisk in the fountain, it will suddenly have a 'tangible' surface. There are probably over 1000 faces to make so that is really a non-starter.

Is the face data still in the original file but just not being read in by the latest Blender? Is there a way to retrieve that data? Is there a faster way to create the new faces?

I've attached a screen shot on my work on the fountain. This is in 3D view with Solid enabled.

Partially fixed (by hand) fountain

Edited to add that I am very new to Blender. I have had some training in Max and Maya, but Blender seems/feels very different (and I haven't really used Maya in about a year so I'm pretty rough at this anyway...).

Here's the original blend file:

I've used the trick in the comments to go through each object in the scene, but I have a lot of blend files for this book so it would be good to know if there's a way to recover the faces more efficiently as I am likely to encounter this problem repeatedly.

Edit:It also looks like most of the normals are wrong, even on my new faces. Flipping the direction seems to work, but there are about 100 faces in this particular model so, again, not very effiecient.

Edit: I installed Blender 2.69 and it mostly works with the old model. There still seems to be a couple of faces that aren't showing but it looks about 95% correct straight from load. Thanks to user Todd for suggesting it. It was released in October of the year the book came out which was December (2013). I don't think I can mark a comment as the answer.

$\endgroup$
6
  • $\begingroup$ Just a thought, try selecting a vertex, hit [Ctrl] + [L] > [F]. Does that do anything useful or does it create too much junk geometry? $\endgroup$
    – PGmath
    Jul 22, 2015 at 3:38
  • $\begingroup$ Have you tried using an older version of Blender? There are lots available. Also, can you post the blend file for us to take a look at it? $\endgroup$ Jul 22, 2015 at 4:54
  • $\begingroup$ How can I add a file that is not an image? $\endgroup$
    – mrmacross
    Jul 22, 2015 at 5:26
  • $\begingroup$ The Ctrl-L > F trick works a little bit. But it doesn't speed up the entire process more than 20-30% since so many of the would-be faces share vertices. $\endgroup$
    – mrmacross
    Jul 22, 2015 at 5:37
  • $\begingroup$ You can post a blend file via a link generated with this service: blend-exchange.giantcowfilms.com $\endgroup$ Jul 22, 2015 at 6:32

2 Answers 2

0
$\begingroup$

I downloaded your file and all the faces are there. My Blender is 2.75, try updating yours :)

But if you still have the problem after updating your Blender, try selecting all the edges and vertices and press space and search for "Fill Holes" and select. This should fix it :)

$\endgroup$
2
  • $\begingroup$ I have 2.75a and it was a fresh install. I wish I had the same results as you. The picture I posted is taken from within my Blender. $\endgroup$
    – mrmacross
    Jul 23, 2015 at 0:41
  • $\begingroup$ I could only find "Fill", not "Fill Holes". It did create some faces, but the geometry was very screwed up. I don't think I can post a picture in a comment, unfortunately. $\endgroup$
    – mrmacross
    Jul 23, 2015 at 0:48
0
$\begingroup$

Todd McIntosh suggested using an older version and it seems to have worked. Version 2.69 came out the same year as the book.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .