1
$\begingroup$

I have frequent kernel crashes (which I haven't solved, but that's another story) that absolutely destroy my Blender save files. If I have a file open in Blender, even if I'm not doing anything to it, it will be corrupted when I try to open it again after rebooting. I'll get the infamous "file format not supported" error and when I check the size of the .blend file, it's 0B.

I also have auto backups turned on, but when I went to check if they were any better, they were also 0B.

I'm not expecting to solve my kernel crashes, but is there a way to make sure these corruptions don't occur, outside of manually backing up my files every 5 minutes?

$\endgroup$
  • $\begingroup$ Kernel crashes can be caused by things external to the kernel like Ram, HD, powersupply not supplying power consistently to these components, or overheating. Blender assumes your computer functions normally, and that's what we assume here at BSE too. I've had failures like this in the past and have relied on the .blend1 and .blend2 files which you can rename. Beyond that this question is out of scope for BSE.. -- i'm not aware of any ultra-defensive mode.. $\endgroup$ – zeffii Jul 20 '15 at 9:51
  • $\begingroup$ save often, save using sequential file names. until you resolve the Kernel / crashing issue $\endgroup$ – zeffii Jul 20 '15 at 9:54
  • $\begingroup$ Blender stores a copy in /tmp (check if that copy is OK). Some distros remove files from /tmp from boot to boot, so you might want to start the machine after a crash from a USB or any other mean that avoids removing /tmp. $\endgroup$ – YoMismo Jul 20 '15 at 10:07
  • 1
    $\begingroup$ @YoMismo My tmp folder was clean, but I've changed the temporary storage folder to something in my /home/username directory. Hopefully that will help. $\endgroup$ – Abluescarab Jul 20 '15 at 10:08
  • $\begingroup$ @zeffii I thought maybe there was a setting in Blender that was constantly accessing the files you open and therefore might cause corruption. Thanks for the suggestions. $\endgroup$ – Abluescarab Jul 20 '15 at 10:09
1
$\begingroup$

Have you tried using the File > Recover Last option? it automatically loads the latest blend file saved to the tmp folder.

By default Blender saves the scene every 2 minutes. You can change the Auto Save duration in User Preferences.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.