5
$\begingroup$

I feel like I've fallen at the first hurdle, importing a DXF file.

By that I mean, I figured out how to enable the dxf import tool, and imported the file I had, but that's about it.

I'm struggling how to manage the workspace and actually view the file I've imported or do anything with it. Maybe I'm doing the import process wrong? Do I import it as a new scene, do I center geometry, etc, etc?

When I selected center geometry I could at least see something, but it looked like my imported file is maybe way to big for the workspace, as all I could see when I zoomed right out, was the first letter or so of some text from the imported file. (see screen shot).

imported dxf in blender

Ok, I went the other way as you pointed out. Used 0.01, which brought a lot more into view, but still very large, so... used 0.001 which brought more into view, but it doesn't look anything like the plans I see in Autodesk?

incorrectly imported dxf

To give you an idea of what it should be looking like, this is it in autocad. View from each side, floor plan for ground and 1st floor... two view of the entire building plot, one showing topography and a street view elevation.

how the dxf should look

Two more Blender screen grabs: this is imported at 0.0001. The first image is relatively close up to the workspace grid, and then second is zoomed out. The closer view looks like I'm getting close to the size I need. In the zoomed out view... I've no idea what is forming the large circular patterns as I can't see anything like that in the original drawings???

Would it help my progress if I removed some of the layers from the original file? I obviously don't need things like drains and internal wood framing, water mains, wiring, etc.

As you can see from the last screen grab... I've kinda got the plans into the work area, but I don't know what is affecting the view. What is causing this grey shading across the work area?

There was more of it, in ever increasing circles going out from the center, but I removed some by hiding certain layers, but can't seem to view just the plans without this shading?

$\endgroup$
  • $\begingroup$ Does it work to hit [A] (toggle select all) and [S] (scale) and scale it in? $\endgroup$ – PGmath Jul 19 '15 at 18:23
3
$\begingroup$

Check scale, center geometry to origin, shift+C, clipping planes...

When importing DXF there are a few options to work with.

enter image description here

One is the scale. The default settings is scale = 1, wich obiuvsly means that Blender will multiply by this factor the incoming units of the DXF.

So if you had drawn with your vectorial software a square of 2mx2m, blender will import an object of 2unitsx2units.

If you were working in cm, your square shall measure 200. If in blender you are going to work in meters, you must put a 0.01 factor...

This is valid also for the location of objects. So it is important to consider also the relative distance of the square from the origin of the sistem. To avoid problems, if Is possible, I would suggest to move the geometry to the origin in your drawing software.

Another tool that may come useful is Shift+C

enter image description here

It will extend your view till all visible objects are in the 3d view. If it seem that the camera de-zoom too far away, there are probably objects much distant from the origin. Notice that they might come outside of the 3D camera's clipping planes, making them invisible.

$\endgroup$
  • $\begingroup$ Thanks for the replies. OK, when doing the import, I set the unit scale to -10.0, and that revealed some more of the text from the plans, but obviously from the screen shot below... it's still huge. Do I just keep going down in scale on the import until it all comes into view? Incidentally, I didn't create the plans. They were created by an architect and (after some resistance) they provided the dwg files for me to try and create a 3D render. $\endgroup$ – Del Jul 19 '15 at 18:48
  • $\begingroup$ If you don't know the units in which the file was drawn, you'll have to try different values till you guess right. Notice that scale factor is meant to be a multiplier, so if comes out too big, next time try a smaller value. Don't use negative values, they flip geometry. $\endgroup$ – Carlo Jul 19 '15 at 18:57
  • $\begingroup$ Hi Carlo, Thanks for your help so far. I used an import scale of 0.0005, which put all the plans within the grid area. But, if you check the new pics in my original post... there's still something not right. Not sure which element is producing the grey sketchy background and preventing me from seeing the plans properly to work with. The original file included everything needed for construction, so... do I need to strip away all that I don't need for an external render and save a dxf file with just the minimal data needed? Any further assistance would be hugely appreciated. Thanks, Del. $\endgroup$ – Del Jul 19 '15 at 23:23
  • $\begingroup$ Maybe is better to continue in a chat room so I can ask you some things.. Would you join me there (chat.stackexchange.com/rooms/26021/…)? $\endgroup$ – Carlo Jul 19 '15 at 23:36
  • $\begingroup$ Ah... because I'm new to this forum, it won't let me use the chat room. $\endgroup$ – Del Jul 19 '15 at 23:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.