12
$\begingroup$

I changed my Blender Units to Metric System, but when I'm building things, my meshes are transparent, i.e. I can see through faces like in wireframe even though my wireframe is turned off. All faces have a light white in non-wireframe mode, but I can still see through them. enter image description here How do I reverse this?

Another issue I get is this

ect1jkE

Looks like clipping is not working properly.

$\endgroup$
  • $\begingroup$ imgur.com/W6bJU5h,KQKUrhZ#0 It's the top part of a door frame $\endgroup$ – Ninjin Jul 19 '15 at 16:31
  • $\begingroup$ Funny, when I reload the project it works, but after some edits or changes it somehow breaks. $\endgroup$ – Ninjin Jul 19 '15 at 16:36
  • $\begingroup$ Check that your normals are facing the same direction. Select all and press Ctrl N $\endgroup$ – cegaton Jul 19 '15 at 16:52
  • $\begingroup$ Already tried. I also get this when using a simple cube. I mean not when I create, but when I do some edits, at some point I get this. $\endgroup$ – Ninjin Jul 19 '15 at 16:54
  • $\begingroup$ Related blender.stackexchange.com/questions/1385/… $\endgroup$ – Carlo Jul 19 '15 at 18:43
16
$\begingroup$

1° Possible cause:

"Limit selection to visible" must be Enabled, if you don't want to see behind faces while in edit mode. You can find the icon in the 3D View bar.

enter image description here


2° Possible cause:

Those are artifacts caused by not appropriate settings of camera's clipping limits for your scene.

enter image description here

This is the "default scene", except from the clipping near limit.


Clipping plane determine the boundary of camera's frustum (which is the portion of space where computations are done). The bigger the boundary , the less precise calculations could be. As the calculation in this case are about visibility, here they comes the strange effects.

It may not seems that your frustum is so big, as in your scene clipping planes seem not to far away from the default settings...but you must consider that in that calculation also global scaling is involved...

enter image description here

The cube is 150mx150m, the near clipping plane is 1mm/0.01=10cm and the far clipping plane is 1000m/0.01=100'000m! The scale of the frustum is not optimal for your geometery. I suggest to lower the value of you far clipping plane.

enter image description here

$\endgroup$
  • $\begingroup$ So, when I'm using metric system, what should I use then? Whatever I try, it doesn't work. When I'm lowering "end" to 50m it looks more crisp now, but why is everyone telling me like... set your settings from 1cm to 1km?? $\endgroup$ – Ninjin Jul 19 '15 at 17:52
  • $\begingroup$ Those you mention are the (almost) default settings, so they are expected to work for a wide range of situations... maybe your scene has some particularities... If you post your blendfile (or a singificant portion of it) on blend-exchange.giantcowfilms.com I'm sure we'll be able to give you further instructions $\endgroup$ – Carlo Jul 19 '15 at 18:14
  • $\begingroup$ Does this means you always have to change these settings for every new project? I'm uploading the file now, looks like it takes some time $\endgroup$ – Ninjin Jul 19 '15 at 18:47
  • $\begingroup$ No, default setting usually works fine, so you don't have to change them. But sometime is needed (ex landscapes..). Your scene doesn't seem one of this cases, it has probably some problems with units scale. I'll be more precise after examinig the file $\endgroup$ – Carlo Jul 19 '15 at 19:22
  • $\begingroup$ So, before we close this. Can I also just change the scale to 1 and before I import my mesh scale back to 0.01? (I wanted to import to Unreal Engine and these guys are saying they need the 0.01 scale) $\endgroup$ – Ninjin Jul 19 '15 at 19:56
5
$\begingroup$

You probably switched off the limit selection to visible button enter image description here.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.