I've been trying to convert a 3D model into the sims 4 as a decorative object "like action figure." I managed to pose him the way I wish but when it comes to mapping his 3 separate textures I can never seem to correctly do so that he looks the way he does in blender. Can someone give me some detailed help?
model in blender exported model with incorrect textures

  • $\begingroup$ Is it a multiple UV with single material, multiple material with single UV, or something more exotic? uploading your blend file would help. $\endgroup$
    – Bithur
    Jul 18, 2015 at 12:59
  • $\begingroup$ dropbox.com/s/fwlrdf1xr3bez67/rkmodel.blend?dl=0 $\endgroup$ Jul 18, 2015 at 14:15
  • $\begingroup$ can't be sure about it without the textures but it seems that the ks material and rkmodel.png texture and rkuv UVmap are what you need, already done but not applied $\endgroup$
    – Bithur
    Jul 18, 2015 at 14:21
  • $\begingroup$ here is the original, it has 3 seperate textures for hair face clothes etc.. i just don't know how to get them all applied to my character dropbox.com/s/bjb2xajccjjjjca/Kenshin.obj?dl=0 $\endgroup$ Jul 18, 2015 at 14:29
  • $\begingroup$ only original obj mesh, no texture $\endgroup$
    – Bithur
    Jul 18, 2015 at 14:32

1 Answer 1


Using the blend file you sent :
In the UV/image editor, click image and in the menu, new image (or Alt+N)
UV image editor
new image
Select the size of your image (512x512 should be enough but let's use 1024x1024), give it a name (like Full Texture) and click ok
image size
You now have a beautiful black image. This is where we'll bake your texture.
Now go in properties panel, click on vertex data tab and click on rkuv in UV Maps. Make sure the camera icon is active on UVMap.
UV select
In 3D view, enter Edit mode with TAB, salect all with A and in the UV/Image editor, select the Full Texture", then go back in object mode (TAB in 3D view)
texture select
In properties panel, go in render tab, in Bake, bake mode click to open the menu and select "Textures"
bake options
Click the Bake button. Your Full texture is baking...
In UV/Image Editor, click Image, Save As image to save your new texture (if you don't, it'll be lost!!)
save image
In properties panel, go to material tab, select ks material
select mat
Now go in Texture tab, click the button to change texture and select your brand new Full Texture
select tex
Back in material tab, delete all but ks materials.
delete mat
Go in Vertex Data tab and delete "UVMap"
del UV
Now you have only 1 material with only 1 texture. If it doesn't show, go in material tab, enter edit mode, select all and click the "assign" button. If your texture doesn't show, go in texture tab and click the refresh button.
assign refresh
now save your file (change the name to keep the original with textures) and you're done !

I don't know much about sims 4 studio, but if you need an OBJ file, open the file menu, select export then wavefront (.obj). give it a name and you'll be able to import it from sims 4 studio and select the Full Texture file as texture. (the old OBJ won't work)

  • $\begingroup$ i think i'm going to have a heart attack....you have no idea how happy you've made me ;_; <--------- tears of joy... $\endgroup$ Jul 18, 2015 at 15:54
  • $\begingroup$ Glad to help :) I was afraid it was a bit too long to be readable... $\endgroup$
    – Bithur
    Jul 18, 2015 at 15:55
  • $\begingroup$ omg no! that was the best method i could have gotten, thank you thank you so much :D $\endgroup$ Jul 18, 2015 at 16:01
  • $\begingroup$ i hope this can stay here as a reference if i need to look back on it? or should i screenshot everything XD lol $\endgroup$ Jul 18, 2015 at 16:02
  • $\begingroup$ Don't worry, it'll be here forever!! (well maybe not forever...) but don't forget to accept the answer if it suits your needs. :) $\endgroup$
    – Bithur
    Jul 18, 2015 at 16:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .