5
$\begingroup$

I have mixed two textures together using black and white values from a noise texture which is connected to a color ramp. How can I apply a displacement map on a plane so that either the texture "A" or "B" is the limiting factor that determines which parts are affected by the displacement modifier within a plane? I want to use a mask layer to adjust the intensity of the displacement with a noise texture, but at the same time limit it to only some parts of the texture combination.

I have applied a rough displacement on my scene which covers the whole plane, but I'm asking this beacuse I want to add some fine details with two (displacement) modifiers. I know you can assign vertex groups to mark off the affected area, but in my case that's not possible, for you can't see any textures in a vertex select mode and it forces you to select them randomly.

There's a link below to give you a better idea about the problem. Areas which I want to add some extra displacement to are marked as red.

Link: https://drive.google.com/file/d/0B4NHszZHPR_1OVFEWEt2UkdON28/view?pli=1

$\endgroup$
6
$\begingroup$

A solution not using the Displace Modifier:

In Cycles, using the Displacement Input Socket on the material Output, you can control the displacement with a combination of texture nodes.

In this example of a simple (subdivided and UV unwrapped) plane, the wave texture is combined with a voronoi texture using an image texture of the letter A as the mix factor. In other words: the voronoi texture will only displace the parts with the letter A.

enter image description here

enter image description here

Note that this is a true 3D displacement of the geometry, not just a bump map:

enter image description here

As of version 2.75, this is only possible using the Experimental Feature set in the Render controls

enter image description here

and enabling True as the Displacement Method for the mesh.

enter image description here

$\endgroup$
  • $\begingroup$ I did what you suggested and had no idea until about a week later that it wasn't working as it should (I didn't have access to my computer and checked your answer pretty carelessly). But anyway, the case is that the displacement of the geometry show up only in the cycles. When I render the scene it just disappears. In addition to that I'm having difficulties to get rid of sharp shadows which cause trouble around protruding and patchy areas. So far I have tried to subdivide the plane, add some extra lightning and recalculated the normals but without much of success. Any ideas? $\endgroup$ – Tayskersantti Jul 26 '15 at 13:58
  • $\begingroup$ can you upload your file? $\endgroup$ – cegaton Jul 26 '15 at 14:29
  • $\begingroup$ Here you go: "drive.google.com/file/d/0B4NHszZHPR_1aE4wTE9sYVdYU0U/…". Just rotate the sun lamp something like 75-85 degrees and you'll get some nasty distorted shadows. $\endgroup$ – Tayskersantti Jul 26 '15 at 17:52
  • $\begingroup$ I'm not sure that this will work on top of the displace modifier. I'll play with it a bit and see. $\endgroup$ – cegaton Jul 26 '15 at 19:13
  • $\begingroup$ Apply the displacement modifiers. In object mode apply scale on your plane (Ctrl+ A->Scale) so that the scale of the plane is 1. In the node editor play with the multiply factors on the multiply node before the displacement. To update the deformation exit and reenter Rendered mode. If the file deforms in preview but doesn't render: disable experimental and enable it again (it is indeed an experimental feature, not fully supported yet) If the displacement is too sharp you need more subdivisions on your plane, and maybe even a subsurf modifier. blend-exchange.giantcowfilms.com/b/374 $\endgroup$ – cegaton Jul 26 '15 at 19:57
2
$\begingroup$

I dont think is currently possible.

Why?

Because there is no Texture node editor for the Displacement modifier.


enter image description here

You'll need to mask the two textures with the procedural texture (excactly how as been done for the diffuse color), make some tweak an put this custom texture, created with the built-in node tree, in the Displace modifier.

This is not currently possible (2.75a) because, as said here (as far as I know things has not changed yet about this) there are some issue implementing this, so you'll not see a Displacement modifier slot next to the four under the arrow in the image above.

enter image description here

and none of the provided texture type is capable to be mixed with another as needed.


enter image description here

You could try to mask the displace modifier with a flipped copy and a Shrinkwrap modifier with limit enabled...but there are a lot of limitations in this kind of approach, so I won't suggest you.

$\endgroup$
  • 1
    $\begingroup$ You can also try baking the textures and combine them in Gimp or PS if you don't really need procedural. $\endgroup$ – Bithur Jul 17 '15 at 4:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.